CUDA toolkit runfile installation fails :: Fedora 18

Hi all,

I tried to install CUDA toolkit 5.5 on Fedora 18 using the runfile.
The driver installtion fails because Nouveau couldn’t be disabled.
I tried installation after rebboting the system, as suggested in the error log. But it didn’t work.

Please find attached the error log

Tagging shared libraries with chcon -t textrel_shlib_t.License accepted by command line option.
Installing NVIDIA driver version 319.37.
For some distributions, Nouveau can be disabled by adding a file in the modprobe configuration directory. Would you like nvidia-installer to attempt to create this modprobe file for you? (Answer: Yes)

One or more modprobe configuration files to disable Nouveau have beenwritten. For some distributions, this may be sufficient to disable Nouveau; other distributions may require modification of the initial
ramdisk. Please reboot your system and attempt NVIDIA driver installation again. Note if you later wish to reenable Nouveau, you will need to delete these files: /usr/lib/modprobe.d/nvidia-installer-disable-nouveau.conf,/etc/modprobe.d/nvidia-installer-disable-nouveau.conf

Can anyone please help to resolve this.

Thanks & Regards,
Nirmal J