Cuda Toolkit v9.1 failed to install

Hi everybody ,

I need your help for cuda toolkit installation. I’m working on Windows 10, with 2 GPUs Titan Xp.
I had drivers 391.35 and I installed Cuda Toolkit v9.0. Unfortunately something went wrong with the installation and even if I could build nbody.exe, I did not have function such as nvidia-smi.
So I contacted a NVidia agent through the chat and I was advised to install the last drivers 397.31 with cleaning of the previous installation and re-install cuda toolkit but v9.1 this time.

After the installation of the latest drivers, it is not possible to install Cuda Toolkit which fails:

  • CUBLAS Development 9.1 not installed
  • CURAND Runtime 9.1 not installed
  • Visual profiler 9.1 not installed
  • CUPTI 9.1 not installed
  • GPU Library Advisor not installed


Do you know what possibly could go wrong?

Thanks for your answer and help

I had the same issue when it comes to installing CUDA Toolkit. I ended up fixing the problem by disabling Visual Studio Integration.

In conjunction I was using the offline installer, extracting it’s data using 7zip and installing it via the setup.exe from there.

Hope this helps.

Thx, I’ll try

@dechlanrules, thanks a lot, it worked actually. So great!

I encountered the same problem and did get my problem fixed using @dechlanrules method! Thank you!

To make it clear for people, you should firstly use 7zip or WinZip to extract the installation file. Then, find and delete the CUDAVisualStudioIntegration file. Run setup.exe and you’re good to go.

moreover, you can also uncheck the “VisualStudioIntegration” option in the custom installation wizard

I would really really prefer to be able to install the visual studio integration too.

I have installed the CUDA 9.1 by unchecking “Visual Studio Intergration”.

But I want to know about whether this METHOD will have some influences if I try to use CUDA with Visual Studio.

you can install cuda 9.0 (just make sure you install cudnn ver 7.0- if needed) with VS 2015… this configuration was installed successfully yesterday … along with TF-GPU and keras…

I wrote to Nvidia to report this.

I tried to reinstall VS2017, uninstall then install it, without success. There is something wrong I don’t know what. I had Nsight 5.5.0 installed, which is newer than the one in cuda 9.1; it might be the problem.

In the meanwhile, I got a workaround to manually install the VS integration: In a virtual machine, I installed W10 1803 and VS2017 15.7.1, and then Cuda 9.1, it worked perfectly. Then you need to copy C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\VC from the VM version to the host.

But I’m not sure that’s everything