CUDA Toolkit v9.2.148 and Visual Studio 2017 15.7.5

Just installed CUDA Toolkit v9.2.148 and opened the samples in Visual Studio 2017 15.7.5

All the sample project loaded. On build project, all 163 projects failed to build with “error MSB8036: The Windows SDK version 10.0.15063.0 was not found”.

Why are the NVidia developers still using this old Windows SDK? This was released 2017-04-05 more than 1 year ago!

NVidia, please advise your developers to upgrade to Windows SDK 10.0.17134.0 (two version ahead). This is INCLUDED with Visual Studio 2017 15.7 and up.

Visual Studio 15.7 is REQUIRED for any developer using .NET Core 2.0 (and 2.1). It is NOT an option to downgrade Visual Studio 2017 15.1

This continues to make CUDA a huge problem for Windows developers.

Taking the CUDA 9.2 samples samples and Retarget solution to Windows SDK Version 10.0.17134.0 and build causes 122 projects to fail to build and 282 errors including “fatal error C1189: #error: – unsupported Microsoft Visual Studio version! Only the versions 2012, 2013, 2015 and 2017 are supported!”

This is unacceptable. If your developers are over 1 year behind the tools, then you can never expect us to be able to work with CUDA.

I am faced with yet another unspecified amount of time of no productivity with CUDA which has been the situation for all of 2019. Clients are complaining and I am losing work.

1 Like

Errors include

fatal error C1189: #error: – unsupported Microsoft Visual Studio version! Only the versions 2012, 2013, 2015 and 2017 are supported!

2> …\BuildCustomizations\CUDA 9.2.targets(712,9): error MSB3721: The command ““C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.2\bin\nvcc.exe” -gencode=arch=compute_30,code=“sm_30,compute_30” -gencode=arch=compute_35,code=“sm_35,compute_35” -gencode=arch=compute_37,code=“sm_37,compute_37” -gencode=arch=compute_50,code=“sm_50,compute_50” -gencode=arch=compute_52,code=“sm_52,compute_52” -gencode=arch=compute_60,code=“sm_60,compute_60” -gencode=arch=compute_61,code=“sm_61,compute_61” -gencode=arch=compute_70,code=“sm_70,compute_70” --use-local-env -ccbin “C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.14.26428\bin\HostX86\x64” -x cu -I./ -I…/…/common/inc -I./ -I"C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.2/include” -I…/…/common/inc -I"C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.2\include" -G --keep-dir x64\Debug -maxrregcount=0 --machine 64 --compile -cudart static -Xcompiler “/wd 4819” -g -DWIN32 -DWIN32 -D_MBCS -D_MBCS -Xcompiler “/EHsc /W3 /nologo /Od /Fdx64/Debug/vc141.pdb /FS /Zi /RTC1 /MTd " -o x64/Debug/clock.cu.obj “C:\Dev\SourceControl\Development\ObjectRaku\CUDASamples\0_Simple\clock\clock.cu”” exited with code 2.
2> Done building target “CudaBuildCore” in project “clock_vs2017.vcxproj” – FAILED.

Just created a new Windows Server 2016 Amazon EC2 p2.xlarge

Installed Visual Studio 2017 and tried to install “cuda_9.2.148_win10_network.exe”

I get “NVIDIA Installer failed”. I have tried restarting the EC2 machine and it still fails.

It does install on client Windows 10.

What has to happen here. Does the CUDA installer not detect the EC2 GPU?