CUDA updated- no CUDA-capable device is detected

Hi friends,

I have recently updated to CUDA 4(the latest package)

Anyway I have a wierd situation.

When I run the ./deviceQuery on standalone Laptop

I get

./deviceQuery Starting...

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 38

-> no CUDA-capable device is detected

[deviceQuery] test results...


But When I connect the Laptop to an external monitor

[deviceQuery] starting...

./deviceQuery Starting...

CUDA Device Query (Runtime API) version (CUDART static linking)

Found 1 CUDA Capable device(s)

Device 0: "GeForce GT 330M"

 CUDA Driver Version / Runtime Version 	4.0 / 4.0

 CUDA Capability Major/Minor version number:	1.2

 Total amount of global memory: 	512 MBytes (536543232 bytes)

 ( 6) Multiprocessors x ( 8) CUDA Cores/MP: 	48 CUDA Cores

 GPU Clock Speed: 	1.10 GHz

 Memory Clock rate: 	790.00 Mhz

 Memory Bus Width: 	128-bit

 Max Texture Dimension Size (x,y,z) 	1D=(8192), 2D=(65536,32768), 3D=(2048,2048,2048)

 Max Layered Texture Size (dim) x layers 	1D=(8192) x 512, 2D=(8192,8192) x 512

 Total amount of constant memory: 	65536 bytes

 Total amount of shared memory per block: 	16384 bytes

 Total number of registers available per block: 16384

 Warp size: 	32

 Maximum number of threads per block: 	512

 Maximum sizes of each dimension of a block:	512 x 512 x 64

 Maximum sizes of each dimension of a grid: 	65535 x 65535 x 1

 Maximum memory pitch: 	2147483647 bytes

 Texture alignment: 	256 bytes

 Concurrent copy and execution: 	Yes with 1 copy engine(s)

 Run time limit on kernels: 	Yes

 Integrated GPU sharing Host Memory: 	No

 Support host page-locked memory mapping: 	Yes

 Concurrent kernel execution: 	No

 Alignment requirement for Surfaces: 	Yes

 Device has ECC support enabled: 	No

 Device is using TCC driver mode: 	No

 Device supports Unified Addressing (UVA): 	No

 Device PCI Bus ID / PCI location ID: 	1 / 0

 Compute Mode:

 	< Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 4.0, CUDA Runtime Version = 4.0, NumDevs = 1, Device = GeForce GT 330M

[deviceQuery] test results...


There is no problem when I revert back to CUDA 3

I have also tried a fresh reinstall and there’s no change. Did anyone face a similar problem.

Please suggest a solution

Thank you

I got the same error after updating to 4.0 in Linux. To fix this set SELinux in permissive mode. Wait a bit and then try again.