CUDA x86 Setup MacOS 10.11.6

I’m trying to run a CUDA x86 program on my mac and I get the following error. I tried reinstalling a special driver for my exact MacOS build (15G1108) and I still get the same error. I dont have any NVIDIA GPU card, I just want to try CUDA x86’

$ ./deviceQuery
./deviceQuery Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL

CUDA x86 requires the PGI toolchain and an appropriate accelerator license.

I don’t know if it is actively supported anymore.

Do you have the PGI accelerator toolchain installed and have you paid for a PGI accelerator license?

As CUDA x86 is a PGI product, you may get better assistance posting your questions on the PGI forums:

http://www.pgroup.com/userforum/viewforum.php?f=12

Is PGI really in business?

I’ve tried asking them whether accelerator is required for CUDA x86 and no response.
I’ve tried posting in their forums but keep getting errors. They responded to my support request saying the forums are fixed, but I still cant post in the forums.

How could I buy their accelerator edition if they cant even answer an email?

PGI is really in business.

However I don’t think cuda x86 is actively supported anymore.

I’m pretty confident that if you want to buy PGI products, you can do so using either of the methods described here:

http://www.pgroup.com/purchase/how-to-buy.htm