Cuda4 does not install on Macbook 10.6, 9400m

My Cuda 3, openCL etc were working fine, following the Getting Started for Cuda 4 on OSX fails to correctly populate at least /usr/local/cuda , nvcc missing. The guide says, to begin with, to clean the cuda and /Developer/GPU Computing directories, I took that to mean
sudo rm -rf /usr/local/cuda

Then install driver and install GPU SDK. Curiously the guide does not explicitly say to reboot after the driver installation, and it does not say when to install the little cudatools package, I tried several variations on the theme here, with reboot, without reboot etc, but in all cases I was left with a sing lib file in the cuda directory, no cuda/bin at all. Using updatedb and locate showed that nvcc does not end up anywhere in the system anyway.

It looks like the installer has some Big Bug (I think the SDK installation finishes too quickly anyway on my system), and the manual needs even stricter wording, just in case. The private download area for Cuda 4 has a tiny .xml file for OSX, does anyone know what’s its purpose?

Thanks,

AT

Hi!

I’m on a MacBook Pro, with the 9400M chip and OSX 10.6.7 installed, CUDA 4 works just fine.

Just follow carefully every step on the “getting started guide”.

Here what I’ve done:

In the Terminal:

sudo rm -rf /Developer/GPU\ Computing

sudo rm -rf /usr/local/cuda

Double clicked on the packages to install them in this order:

CUDA Driver

CUDA Toolkit

Modified ~/.bash_profile to have:

export PATH=/usr/local/cuda/bin:$PATH

export DYLD_LIBRARY_PATH=/usr/local/cuda/lib:$DYLD_LIBRARY_PATH

Then reloaded the new bash settings:

source .bash_profile

Installed the last package:

CUDA SDK

No reboot needed.

Hope this can work for you too.