cudaprof: No such file or directory First time running CudaVisualProfiler

Hi all,
I just installed the CudaVisualProfiler 1.1beta on my system (Xubuntu 8.04 64bits) GTX 280. Everything seems fine during installation but then when I tried to run the profiler I got the next message:

“/usr/local/cuda/CudaVisualProfiler/bin/cudaprof: No such file or directory”

any clue?


Does the file exist? Is it executable?

good point, but yes… it exists:

root@hankd-desktop:/usr/local/cuda# ls -l /usr/local/cuda/CudaVisualProfiler/bin/

total 16628

-rwxr-xr-x 1 2402 dip 859653 2008-11-13 02:20 cudaprof

-rwxr-xr-x 1 2402 dip 23444 2008-11-13 02:20

-rwxr-xr-x 1 2402 dip 1247580 2008-11-13 02:20

-rwxr-xr-x 1 2402 dip 2371360 2008-11-13 02:20

-rwxr-xr-x 1 2402 dip 10195760 2008-11-13 02:20

-rwxr-xr-x 1 2402 dip 567928 2008-11-13 02:20

-rwxr-xr-x 1 2402 dip 1154464 2008-11-13 02:20

-rwxr-xr-x 1 2402 dip 253028 2008-11-13 02:20

-rwxr-xr-x 1 2402 dip 295588 2008-11-13 02:20

did you add /usr/local/cuda/CudaVisualProfiler/bin/ to the LD_LIBRARY_PATH environment variable?

Thank you for the replies,

yes, I added the path to the LD_LIBRARY_PATH environment variable. This is the extract of the .bashrc file:




export PATH=$PATH:/usr/local/cuda/bin

#export CUDA_PROFILE=0

export CUDA_PROFILE=1"

As you can see I tried both CUDA_PROFILE=0 and CUDA_PROFILE=1 but it didn’t work.

Perhaps you need to add /usr/local/cuda/CudaVisualProfiler/bin to your $PATH ?

Did this ever get resolved? I have the same problem as the poster did.
That is, any attempt to run cudaprof will result in “No such file or directory”
The file is there, I can even use auto-complete when going to try and launch it.

I am also running 64 bit Ubuntu 8.04 with a 280.
I tried both the 1.1 and 1.0 versions of the profiler, both gave the same error.

It will run on my Fedora box.

running “file” on it says that it is a 32 bit application. Could the problem be related to that?

I read yesterday on these forums that ubuntu is the same in this respect as debian. 64bit debian/ubuntu does not allow to run 32bit executables.