cuDF installation issues on Ubuntu

With:

  • Ubuntu 18.04
  • Python 3.8

Just tried using the RAPIDS release selector at Getting Started | RAPIDS (which is really helpful)
to install CUDA 10.2 including cuDF.

However when trying import cudf in Python, there are exceptions reported related to pyarrow

By default, conda was installing version 3.0.0 of pyarrow. Tried to uninstall/down-version back to 0.17.1 and still get different exceptions every time.

Is there any recommendation for which dependencies and their versions to use to get cuDF running?

Looking at its installer, cuDF only requests dependencies for numba and cython – which doesn’t seem correct?

FWIW, there didn’t appear to be any conda YAML in the repo, as far as I could tell – must be packaged elsewhere.

Hey @pacoid , can you retry the installation, but with stable, not nightly (for debugging). Overwrite the existing environment; don’t try to downgrade. Conda handles your multiple environments, using conda activate and deactivate.

What version conda are you running? The solver really should be resolving to pyarrow version 1.0.1 for 0.18.

The yaml files for cudf are here (version 0.19 as reference): cudf/conda/environments at branch-0.19 · rapidsai/cudf · GitHub

Just FYI, I the RAPIDS release selector doesn’t actually install CUDA 10.2, but only cudatoolkit for 10.2 :).

Please get back to me as you can!

1 Like

Many thanks @tdyerNV -
that worked great!

1 Like