cudnn

hello
i installed jetpack 3.1 and it seems like cudnn libarary didnt installed.
i cant find libarary files on cuda-8.0 lib folder
and when i try to compile .cu file. it shows error saying there is no reference to cudnn~
please let me know how to solve this problem
thank you

Hi yuhnjin, cuDNN isn’t installed in the CUDA toolkit, instead it resides in /usr/lib/aarch64-linux-gnu/

Can you find it there? You may need to add the directory to your linker path (-L option)

Hello,
thank you, i found cuDNN in the folder you told me
and tried to put the path on ~/.bashrc file with export LD_LIBRARY_PATH
but it still doesn’t work.
sorry i am very novice with linux and gpu so would you tell me other way to add the directory to my linker path?

LD_LIBRARY_PATH is for the runtime loading of shared objects - you may still need to add the path to your compiler’s (gcc/g++) command line. Try appending this to your command line:

-L/usr/lib/aarch64-linux-gnu/ -lcudnn

The -L option adds a linker path, and the -l option specifies library to link against.