cuGraphicsGLRegisterBuffer failed with error(219) gst_eglglessink_cuda_init texture = 1

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) nvidia-smi
Tue Dec 20 09:32:39 2022
| NVIDIA-SMI 510.108.03 Driver Version: 510.108.03 CUDA Version: 11.7 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
| 0 Tesla V100-PCIE… Off | 00000000:65:00.0 Off | 0 |
| N/A 53C P0 28W / 250W | 48MiB / 16384MiB | 2% Default |
| | | N/A |

| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |

• DeepStream Version Docker
• JetPack Version (valid for Jetson only)
• TensorRT Version Docker
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
**• How to reproduce the issue ?

xhost +
docker run --gpus all -it --rm --net=host --privileged -v /tmp/.X11-unix:/tmp/.X11-unix -e DISPLAY=$DISPLAY -w /opt/nvidia/deepstream/deepstream-6.1

cd samples/configs/deepstream-app
deepstream-app -c source4_1080p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt

after this Get below error…
Debug info: gsturidecodebin.c(920): unknown_type_cb (): /GstPipeline:pipeline/GstBin:multi_src_bin/GstBin:src_sub_bin3/GstURIDecodeBin:src_elem
WARNING from src_elem: No decoder available for type ‘audio/mpeg, mpegversion=(int)4, framed=(boolean)true, stream-format=(string)raw, level=(string)2, base-profile=(string)lc, profile=(string)lc, codec_data=(buffer)119056e500, rate=(int)48000, channels=(int)2’.
Debug info: gsturidecodebin.c(920): unknown_type_cb (): /GstPipeline:pipeline/GstBin:multi_src_bin/GstBin:src_sub_bin1/GstURIDecodeBin:src_elem
cuGraphicsGLRegisterBuffer failed with error(219) gst_eglglessink_cuda_init texture = 1
** INFO: <bus_callback:180>: Pipeline running

**PERF: FPS 0 (Avg) FPS 1 (Avg) FPS 2 (Avg) FPS 3 (Avg)
**PERF: 0.00 (0.00) 0.00 (0.00) 0.00 (0.00) 0.00 (0.00)
**PERF: 398.37 (1.06) 398.37 (1.06) 398.37 (1.06) 398.37 (1.06)
**PERF: 0.00 (0.52) 0.00 (0.52) 0.00 (0.52) 0.00 (0.52)
ERROR from secondary_gie_bin_queue: Internal data stream error.
Debug info: gstqueue.c(988): gst_queue_handle_sink_event (): /GstPipeline:pipeline/GstBin:secondary_gie_bin/GstQueue:secondary_gie_bin_queue:
streaming stopped, reason not-negotiated (-4)
ERROR from sink_bin_queue: Internal data stream error.
Debug info: gstqueue.c(988): gst_queue_handle_sink_event (): /GstPipeline:pipeline/GstBin:processing_bin_0/GstBin:sink_bin/GstQueue:sink_bin_queue:
streaming stopped, reason not-negotiated (-4)
[NvMultiObjectTracker] De-initialized

to give more information in advance: I already have connected a physical display currently using by taking remote access.

Your card is a compute card (Telsa V100), Please refer to the explanation here: cuGraphicsGLRegisterBuffer failed with error(219) gst_eglglessink_cuda_init texture = 1 - #3 by Amycao

Are referring to …
5Q: Customer commonly met sometimes need to output to screen, but just with Tesla card which used as compute card, 2 ways to get through


  1. Output to sink type 1 Fakesink or 3 File;

  2. A hacky way to use Tesla p4 for virtual display, but just suggest for developments, since it will take some percent of device memory, finally impact the inference perf

    first need to install nvidia graphic driver with opengl installed

    sudo nvidia-xconfig --query-gpu-info
    Number of GPUs: 2
    GPU #0:
    Name : Tesla T4
    UUID : GPU-b58f5878-b235-c28e-4e2a-44d8623d133a
    PCI BusID : PCI:3:0:0
    Number of Display Devices: 0
    GPU #1:
    Name : Tesla P4
    UUID : GPU-55bc88aa-fc94-0e86-9319-abd5fadf49ab
    PCI BusID : PCI:4:0:0
    Number of Display Devices: 0
    sudo nvidia-xconfig --busid=PCI:4:0:0 --allow-empty-initial-configuration
    reboot system, install nomachine from your windows system, and also need install nomachine on your linux server which have p4 installed, and login to desktop
    using nomachine from windows system.

Could you explain the process once because I hope you understand it’s a server and I don’t have root access I would need to communicate everything to administrator once again.

So please tell me how to install nvidia driver with opengl and kindly tell me every step that has to be followed. I never though that working with deepstream can be this pain. This is the 4th card I am trying. I really appreciate your help.

Unfortunately the root privilege is needed to install the correct driver.

okay, we can get this done. but can you tell me what steps are required to be followed so that communication can be reduced.
In short please point out what and how needs to be installed to get the Deepstream running. I did not quit understand the above installation steps recommended by your team mate.

Please follow Quickstart Guide — DeepStream 6.1.1 Release documentation

Did you even bother to read the error and previous comments @fiona. please just don’t copy past stuff. I have already referred guide several times.

Hi @ yingliu could you elaborate more on your comment please, I need to ask the root administrator to install whatever you ask.

I don’t have a server environment to practice the commands, sorry.
For the server use case, normally it can be saved to a file, or a local RTSP server so your client can read the stream from the server.
You can try to start with deepstream_app example and set the sink to file (type 3 in your example), there will be output file defined by “output-file” and you can download it to view the behavior.

@yingliu, We’ve got ubuntu installed in this server just for the use of deepstream and Currently I am working on it via remote access via ‘rdb’ and we have got a display connected with this as well.
Thing is we want to develope a multi camera tracking app by selecting region of interest in one of the video feed and for that we need to render output on display. type 3 is working fine but that’s something we don’t need at all

The nveglglessink does not support remote display. So you need a real local display (physical or virtual) with Nvidia GPU.

Either you run the app locally but not from remote access, or you use a remote desktop tool which support remote Ubuntu desktop to run the app.

@fiona.chen I cannot run it locally as it’s a remote machine but does have a physical monitor connected which I got it done. I can access remotely.

Therefore, could you tell me the remote desktop tool which support remote Ubuntu desktop to run the app.

There is no such tool provided by Nvidia. You can google for it. Such as NoMachine, VNC, …

@Fiona.Chen I’ve tried once again and this time using vnc…still getting same error…

Anyone there?

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

Are you run the command in VNC client? Can you run any X11 based app in your terminal?

Please make sure X11 is configured correctly with the VNC client. It is not DeepStream related. Please google by yourself.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.