Custom Byte tracker

Please provide complete information as applicable to your setup.

• Hardware Platform (GPU) 1660ti
• DeepStream Version 6.0
• TensorRT Version 8.0.1
• NVIDIA GPU Driver Version (valid for GPU only) 470.82.01
• Issue Type: dlopen error: /path/to/library/ undefined symbol: _ZN2cv6String10deallocateEv

I’ve followed the repository Byte-Deepstream to created a library from the Byte Track CPP code and passed it as the custom low level tracker library for NvTracker plugin. Since the code for NvTracker is closed source, its difficult to get to the root cause of the issue.

Here is my config file
config.txt (5.1 KB)

I run this with deepstream-app -c /path/to/config.txt when I run the command I get this error message

Warning: 'input-dims' parameter has been deprecated. Use 'infer-dims' instead.
gstnvtracker: Loading low-level lib at /path/to/Byte-Deepstream/lib/
gstnvtracker: Failed to open low-level lib at /path/to/Byte-Deepstream/lib/
 dlopen error: /home/ahmedtarek/trackers/Byte-Deepstream/lib/ undefined symbol: _ZN2cv6String10deallocateEv
gstnvtracker: Failed to initilaize low level lib.
0:00:00.158945660 20584 0x5587629cd560 ERROR              nvtracker gstnvtracker.cpp:265:gst_nv_tracker_start: gstnvtracker: Failed to initialize trackerIface

0:00:00.158979796 20584 0x5587629cd560 WARN                GST_PADS gstpad.c:1149:gst_pad_set_active:<tracking_tracker:sink> Failed to activate pad
** ERROR: <main:658>: Failed to set pipeline to PAUSED

can you help me please with this error ?

Seems open your low level tracker library fail.

Thanks for your reply.
I know that do you have any idea why it fails or how can I debug this ??

undefined symbol: _ZN2cv6String10deallocateEv

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.