Custom Camera Driver missing after installtion of jetpack in Xavier AGX

I built a custom camera driver in AGX and its working perfectly fine until I install jetpack using the following command “sudo apt install nvidia-jetpack”. after installation of jetpack the camera driver works fine but after restart I am not getting ui to solve it I loged into agx using ssh and used the “sudo apt-get upgrade” command after that I am able to get the ui back but my custom driver and the corresponding device tree is missing.

How to solve it any suggestions please ?

By default apt-get upgrade will re-install the whole L4T OS to the board again.

If you want to prevent it. Remove nvidia related sources from your apt source.

hi @WayneWWW ,
I had a look on the file in /etc/apt/sources.list all that there was related to ubuntu related sources.
there was a source file in /etc/apt/sources.list.d/nvidia-l4t-apt-source.list which had the below two lines

deb r32.6 main
deb r32.6 main

I commented the above lines and tried to ‘sudo apt upgrade’ my driver file was there but I am still not getting the ui mode, but when thoose lines are not commented I get ui but my driver and device tree goes missing.
Is there any way to solve it?

I don’t know what happen to your UI so cannot provide a method to solve it.

To debug, you can dump the /var/log/Xorg.0.log.

Hi Wayne ,
I found out that when I install “sudo apt install nvidia-jetpack”
this file in my Xavier remains same while all the others are upgraded to 32.5.2 and one of the files expect

Please have a look at the log below from Xorg.0.log

(EE) Failed to load /usr/lib/xorg/modules/extensions/ cannot open shared object file: No such file or directory

Is there anyway to solve it ?

It looks like a known issue. Let me check internally.

Hi varun.p,

What JetPack image are you flash?
You can use below command to check release build:

$ head -1 /etc/nv_tegra_release

Check on our Xavier devkit with r32.6.1, after run ‘apt update && apt upgrade && apt install nvidia-jetpack’, there are no issue.

Hi @carolyuu ,
I am facing this issue in both 32.6.1 and 32.5.0

Hi varun.p,

Can you describe more detail about your steps?
Flash r32.6.1 on Xavier
Run apt-update && apt-upgrade && apt install nvidia-jetpack
Reboot device → got no GUI ?

Hi @carolyuu ,
This is what I did

  1. To test the custom camera driver I tried " gst-launch-1.0 nvarguscamerasrc ! nvvidconv ! xvimagesink" and got the camera streaming properly.

  2. I used “sudo apt-get update” then “sudo apt-get install nvidia-jetpack” after the installation of nvidia-jetpack I tried the 1st step and it was working

  3. After Reboot I got no ui

  4. I logged in through ssh and used “sudo apt-get upgrade” and got ui after reboot but my camera driver and device tree were missing.


Please treat 32.6.1 and 32.5 as different issue.

Share the full xorg.0.log log for 32.6.1 and also 32.5 after error happened.

Do not parse any log for me. I just need the full log.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.