Custom carrier board startup failed

Hi everyone
We have customized a nano board, and the serial port debugging information after startup is often failed after [0000.810] Performing RAM repair
May I ask the possible reason for hanging up?What are the processes before and after system startup to execute here?Serial debugging information is as follows:

0000.126] [TegraBoot] (version 00.00.2018.01-l4t-24abfa75)
[0000.131] Processing in cold boot mode Bootloader 2
[0000.135] A02 Bootrom Patch rev = 1023
[0000.139] Power-up reason: pmc por
[0000.142] No Battery Present
[0000.145] pmic max77620 reset reason
[0000.148] pmic max77620 NVERC : 0x40
[0000.152] RamCode = 0
[0000.154] Platform has DDR4 type RAM
[0000.157] max77620 disabling SD1 Remote Sense
[0000.161] Setting DDR voltage to 1125mv
[0000.165] Serial Number of Pmic Max77663: 0x1b09a3
[0000.173] Entering ramdump check
[0000.176] Get RamDumpCarveOut = 0x0
[0000.179] RamDumpCarveOut=0x0,  RamDumperFlag=0xe59ff3f8
[0000.184] Last reboot was clean, booting normally!
[0000.189] Sdram initialization is successful
[0000.193] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0000.199] Lp0 Carveout Base=0x00000000ff780000 Size=0x00001000
[0000.205] BpmpFw Carveout Base=0x00000000ff700000 Size=0x00080000
[0000.211] GSC1 Carveout Base=0x00000000ff600000 Size=0x00100000
[0000.217] GSC2 Carveout Base=0x00000000ff500000 Size=0x00100000
[0000.223] GSC4 Carveout Base=0x00000000ff400000 Size=0x00100000
[0000.228] GSC5 Carveout Base=0x00000000ff300000 Size=0x00100000
[0000.234] GSC3 Carveout Base=0x000000017f300000 Size=0x00d00000
[0000.250] RamDump Carveout Base=0x00000000ff280000 Size=0x00080000
[0000.256] Platform-DebugCarveout: 0
[0000.260] Nck Carveout Base=0x00000000ff080000 Size=0x00200000
[0000.266] Non secure mode, and RB not enabled.
[0000.316] Csd NumOfBlocks=61157376
[0000.379] Using GPT Primary to query partitions
[0000.387] Loading Tboot-CPU binary
[0000.774] Verifying TBC in OdmNonSecureSBK mode
[0000.784] Bootloader load address is 0xa0000000, entry address is 0xa0000258
[0000.791] Bootloader downloaded successfully.
[0000.795] Downloaded Tboot-CPU binary to 0xa0000258
[0000.800] MAX77620_GPIO5 configured
[0000.803] CPU power rail is up
[0000.806] CPU clock enabled
[0000.810] Performing RAM repair
[0000.813] Updating A64 Warmreset Address to 0xa00002e9

Best regards!

Hi, is it same result with dev kit carrier board? What’s the changes of your board to dev kit?

Hi Trumany
There are no similar problems with the dev kit carrier board, we have made few changes compared to the dev kit carrier board, we use the original L4T system, some boards start up normally, but the other boards have such similar problems.
we would like to know the process before and after the startup program is executed to [0000.810] Performing RAM repair, so that we can check the possible cause of the problem.

Best Regards!

It looks like a board issue. You can check the boot info of normal board to find out the process before and after RAM repair.

In addition, is there an EEPROM like dev kit on your board?

Hi Trumany
There is no EEPROM on our custom board. Is it necessary? What does it do?
Another question is : In addition to software shutdown and manual shutdown, when will force off output low level.



Please use below attachment to replace the nvtboot.bin under Linux_for_Tegra/bootloader/t210ref/.

and share the boot log (uart) with us.
nvtboot.tar.gz (75.4 KB)

Hi WayneWWW

Best regards!

Hi WayneWWW
Thank you for your reply. We have solved the problem.The cause of the problem appears to be a hardware design problem.

Best regards!

Can you share what the hw problem is? Thanks.

I’d be also interested in your solution.