Custom Carrier Shutdown

I am verifying my carrier board design with Jetson Nano 2GB module. Everything is working fine (usb2, usb3, pcie nvme, gpio, micro usb, uart serial, recovery mode). There is no HDMI, CSI, or ethernet. I disabled these in device tree.

The only issue I am facing is during shutdown. Serial console reports:

systemd-shutdow: 32 output lines suppressed due to ratelimiting
IRQ10 no longer affine to CPU1
CPU1: shutdown
IRQ11 no longer affine to CPU2
CPU2: shutdown
IRQ12 no longer affine to CPU3
CPU3: shutdown
reboot: Power down

at which point the power led shuts off and the fan will go into full speed and not shut off. Setting the fan speed with /sys/devices/pwm-fan/target_pwm works as expected when the system is running so I don’t think it’s a problem with hardware.

Previously when testing software with dev board carrier, I had set DefaultTimeoutStartSec and DefaultTimeoutStopSec of /etc/systemd/system.conf to small number and this worked, but not with custom carrier.

I am using a custom Kernel and usb2 is always on using regulator@10 vdd-usb-vbus2 like in reference design.

I am attaching results of journalctl -rb -1

Comparing these stopped services with the enabled systemd services, it seems as though systemd-udevd.service and haveged.service never get stopped.

What can I do?

by the way I’m proud of my work:


so your issue is that the fan still runs in full speed when the device is powering off?
Just to make sure, it will stop after the device is completely shut down?

Thanks for getting back to me. Yes, that’s right. Fan runs full speed when powering off after the power LED shuts off.

I have let it run for at least 10 minutes in this state, and it does not stop. I have to physically cut 5V. Also, I don’t know how else to debug the issue since serial console doesn’t tell me anything else.


can you check the hardware design, and see if currents are still transferred to the fan after power off?
This does not sound like a software issue, so you may not be given anything useful from serial console.

Hi Dave,
Thank you. So I have been barking up the wrong tree.
I will check the signals and current draw.
I have seen other reports of users with the same issue. They solved it by placing an additional pull down resistor on FAN_PWM_Q*.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.