Custom vdb node size error in gInteractiveOptix sample

Hello,

I’m trying to include gvdb to my cuda path tracer but I’m having some trouble rendering a custom sparse volume vdb file (I can convert and render levelset vdb files with no problem). To test gvdb I’ve exported a vdb file from Houdini 17.5 and converted to a vbx file as shown in gImportVDB sample, and tried to render it in gInteractiveOptix sample but I’m getting an error as:

Creating OptiX context.
Setting Ray Generation program.
  Loading: optix_trace_primary.ptx, trace_primary
  Loading: optix_trace_primary.ptx, exception
Setting Miss program.
  Loading: optix_trace_miss.ptx, miss
Creating random number buffer.
Creating Mesh intersection programs.
  Loading: optix_mesh_intersect.ptx, mesh_intersect
  Loading: optix_mesh_intersect.ptx, mesh_bounds
Creating Volume intersection programs.
  Loading: optix_vol_intersect.ptx, vol_intersect
  Loading: optix_vol_intersect.ptx, vol_levelset
  Loading: optix_vol_intersect.ptx, vol_deep
  Loading: optix_vol_intersect.ptx, vol_bounds
Creating OptiX Main Group and BVH.
PERF_INIT: No CPU markers.
PERF_INIT: No GPU markers.
PERF_INIT: Disabling perf. No CPU or GPU markers.
  Device List:
Max. texture3D width: 4096
Max. texture3D height: 4096
Max. texture3D depth: 4096
   0. GeForce GTX 680
   Using Device: 0, GeForce GTX 680, Context: 0000024BAE5E7000
Starting GVDB Voxels. ver 1.11
 Creating Allocator..
 Creating Scene..
 Creating CUDPP..
Loading polygon model.
Loading VBX. D:/REPOS/gvdb-voxels/source/shared_assets/dragon_volume.vbx
LoadVBX: D:/REPOS/gvdb-voxels/source/shared_assets/dragon_volume.vbx (ver 1.11)
Sizes: char 1, int 4, u64 8, float 4
ERROR: VBX file contains nodes incompatible with current gvdb_library.
       Size in file: 1024,  Size in library: 64
Error. Application will exit.

My question is what can be affecting the size of nodes in openvdb file? Did anyone manage to convert their own vdb file?

FYI:

houdini 17.5 uses openvdb version 5.2.0 (https://www.sidefx.com/docs/houdini/licenses/). I’ve built the gvdb libraries and tried with openvdb 5.0.0 and 5.2.0. The error is same. The openvdb file contains 2 channels (density and temperature). Is a specific naming is used in explosion.vbx file? or is there a guide about conversion of sparse volume files?

My system:

Windows 10 Pro
Visual studio 2017 (v141) x64, SDK 10.0.17763.0 (also tried 2015.3 (v140))


Capture2.jpg
vdb_and_Vbx_files.zip (12.9 MB)

Capture2.jpg