Customized Camera Program showing "STREAM_TYPE_EGL not found" error

Hi There,

I’m working on migrating our existing project to Orin NX and JP5.1. We got the camera sensor working and the argus_camera works good.

However, when I try to run our existing program binary. I got the " STREAM_TYPE_EGL not found" error. The error message is similar to this.

(Argus) Error BadParameter: Argus capture intent STREAM_TYPE_EGL not found (in src/common/ScfTranslate.cpp, function toScfUseCase(), line 557)
(Argus) Error BadParameter:  (propagating from src/api/CaptureSessionImpl.cpp, function createRequest(), line 596)

The same process previously worked with Xavier NX + JP5.0 DP. The binary was built with Argus 0.98.

I’m wondering if people had similar issue before.


hello jdluckyday,

you can access to the sensor stream by v4l standard control or gst pipeline with nvarguscamerasrc plugin, right?

this should be an issue with app implementation,
did you create output stream with STREAM_TYPE_EGL?
may I know what’s the capture intent you’re using? for example, CAPTURE_INTENT_PREVIEW , CAPTURE_INTENT_STILL_CAPTURE , or something else?

did you also use the latest release sources to compile the app for JP-5.1?
according to Argus Camera API Release Notes, Argus release sources should be
Release 0.99.2 (01/24/2023)

Hi Jerry,
Thanks for checking! Yes, the sensor passed regular v4l2-ctl test and it’s showing correct setting and fps.

We’re using the default INTENT (we left it empty): CAPTURE_INTENT_PREVIEW.

We complied the App using 0.98.3 (from JP5.0DP). The argus_camera sample app printed out saying argus_version as 0.98.3.
The sample app source was obtain on device (JP5.1) with sudo apt install nvidia-l4t-jetson-multimedia-api

Hi Jerry,

Quick update. I recompiled the app with the new libargus from the device and it worked. The release note says it is 0.99.2 as you pointed out.

Not so sure why the version from the sample apps are still 0.98.3. And the the version number printed from my app is actually >?Ϊ?


hello jdluckyday,

thanks for confirmation.
I see there’s an error by printing Argus version, and there’s bug internally.

Thanks for helping out! Please feel free to close this topic.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.