Customized kernel working on Jetson Nano production module do not work on Nano developer kit (B01)

I have a problem with flashing new Jetson Nano developer kit module (B01) with customized kernel, which is already working on another Jetson Nano production module version. I am flashing from sdk manager. If I flash from clear L4T sources, downloaded with sdk manager, devkit boots and works normaly, but when I make changes in kernel according to working production module, than compile kernel and flash it with sdk, the boot stucks. (see image below) .
(I tried only to change these two files in device tree tegra210-porg-pinmux-p3448-0002-b00.dtsi, tegra210-porg-gpio-p3448-0002-b00.dtsi)

Q1: What can cause this problem?
Q2: Are there any difference between production module and new developer kit except memory type ?

Thanks for a reply.


If you only replace the kernel, there should be no such problem.

Please tell us what you’ve done and command you are using. If you don’t change those dtsi files, would you hit this issue?


If I use default tegra210-porg-pinmux-p3448-0002-b00.dtsi and tegra210-porg-gpio-p3448-0002-b00.dtsi files, then Jetson boots normally.

These are the steps I follow:

  • replace pinmux dtsi files with the ones generated with pinmux spreadsheet (already working on production module)
  • compile kernel (finish with success)
  • replace Linux_for_Tegra/kernel/dtb/ and Linux_for_Tegra/kernel/Image files with ouputs of compilation
  • install the kernel modules to Linux_for_Tegra/rootfs
  • next flash jetson nano dev kit via SDK Manager

Could be something wrong with generated pinmux files if they are already working on production module ?


Hi tomfreakk,

There is something that I cannot understand. For those dts with “p3448-0002”, they are for production module and devkit module will not use them. It means it does not matter whether you changed those two dtsi files. If you make sure you didn’t pick up the wrong board config during flash, it will not get flashed.

Also, in your steps, you didn’t mention the update of dtb but only kernel.

Hi, thank you so much for your quick reply.

Every time after compilation of kernel I copy generated dtb files to kernel/dtb and then I execute complete target flash with sdk manager, so I think that all the files are flashed during this process. Or do I missing something ?

But now, after your explanation I know I am making changes in wrong dtsi files , so I will try to change right files and then I will post the result.

Hi @WayneWWW ,
So I try to make changes in right pinmux files for devkit (p3448-0000) and everything work as expected. I don’t know how the boot process was affected by making changes in wrong files, but this solved my issue. Thank you so much for your help .