Customized Logo for Xavier NX

We have confirmed the customized logo with Jetson AGX Orin(JetPack 5.0.2) with reference to below:
https://docs.nvidia.com/jetson/archives/r35.1/DeveloperGuide/text/SD/Bootloader/UEFI.html#customized-logo

However, we could not have worked well with Jetson Xavier NX(JetPack 5.0.2).
How can we carry out with Jetson Xavier NX(JetPack 5.0.2)?

thanks

You can try to describe what you’ve tested… it would be better than only telling me you failed…

We have tested “the customized logo” with Jetson AGX Orin(JetPack 5.0.2) and worked well but, Xavier NX(JetPack 5.0.2) cannot do it as the AGX Orin. Xavier NX cannot bring up with the reference.

Are you using DP monitor or HDMI monitor?

We used the HDMI monitor.

thanks

Sorry that could you elaborate what is your “cannot work mean”? The logo cannot show up? or the logo didn’t change?

I just tested again and the logo can change on my side.

When I used the Xavier NX(JetPack 5.0.2) for “the customized logo”, the logo didn’t change(it was the black screen) and also even the Xavier NX didn’t bring up.

I just tested again and the logo can change on my side.

->Did you use not the AGX Orin but the Xavier NX?

Does the Xavier NX support for “the customized logo” because the following document says that it is for For the Jetson AGX Orin?
https://docs.nvidia.com/jetson/archives/r35.1/DeveloperGuide/text/SD/Bootloader/UEFI.html#customized-logo

Hi,

Honestly, it is kind of wasting time to hear you keep looping the same comment again and again. Your comment has nothing provided. It is just “it does not work and I cannot provide anything else”.

How about you just shared the whole steps you’ve done on your side? or at least some logs?

Maybe your step is wrong or something else go wrong. We need your steps to check what happened.

Also, I tested on Xavier NX.

Hi Wayne,
I’m sorry for wasting your time.
This is our step below:
・UEFI sources and compilation

we installed edk2-nvidia and got the source of nvidia-uefi on the ubuntu18.04LTS PC.

sudo apt-get install git python3 python3-setuptools python3-pip
mkdir edkrepo
cd edkrepo
wget https://github.com/tianocore/edk2-edkrepo/releases/download/edkrepo-v2.1.2/edkrepo-2.1.2.tar.gz
tar xvf edkrepo-2.1.2.tar.gz
sudo ./install.py --user ${USER}
cd …

sudo chown -R ${USER}. ~/.edkrepo
edkrepo manifest-repos add nvidia https://github.com/NVIDIA/edk2-edkrepo-manifest.git main nvidia

edkrepo clone nvidia-uefi NVIDIA-Jetson main

cd nvidia-uefi

more edk2-nvidia/Platform/NVIDIA/Jetson/Build.md

Follow instructions in Build.md

  1. Install all required packages:

    sudo apt-get update
    sudo apt-get install build-essential uuid-dev git gcc python3 \
                         virtualenv gcc-aarch64-linux-gnu \
                         device-tree-compiler
    
    
  2. Install mono following the edk2-pytool note on NuGet on Linux.

sudo apt install gnupg ca-certificates
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
echo “deb https://download.mono-project.com/repo/ubuntu stable-bionic main” | sudo tee /etc/apt/sources.list.d/mono-official-stable.list
sudo apt update
sudo apt upgrade (if mono is already installed)

  • or -
    sudo apt install mono-devel

・Customized Logo
cd nvidia-uefi

we set the bmp file we would like to edit under edk2-nvidia/Silicon/NVIDIA/Assets

Editing the following file:
edk2-nvidia/Platform/NVIDIA/NVIDIA.fvmain.fdf.inc

Logo Files

FILE FREEFORM = gNVIDIAPlatformLogoGuid {
SECTION RAW = Silicon/NVIDIA/Assets/640-480.bmp
SECTION RAW = Silicon/NVIDIA/Assets/1280-720.bmp
SECTION RAW = Silicon/NVIDIA/Assets/1920-1080.bmp
}

Running build.sh:
./edk2-nvidia/Platform/NVIDIA/Jetson/build.sh

We confirmed the two files under images:
uefi_Jetson_DEBUG.bin
uefi_Jetson_RELEASE.bin

We renamed uefi_Jetson_RELEASE.bin to uefi_Jetson.bin under /nvidia/nvidia_sdk/JetPack_5.0.2_Linux_JETSON_XAVIER_NX_TARGETS/Linux_for_Tegra/bootloader

Finally, flashed to Xavier NX.

Could you tell me the wrong step if the steps are not good?

1 Like

Could you attach the bmp file you are using here?

This is the bmp file.
bmp_logo.zip (63.5 KB)

I would like to know if the steps are wrong or good.
Could you also answer for it?

thanks

Hi A_Y,

Please try attached bmp file.
fullycharged1080.bmp (524.6 KB)

Put bmp file in edk2-nvidia/Silicon/NVIDIA/Assets
Change the file name in Platform/NVIDIA/NVIDIA.fvmain.fdf.inc
Try clean build the UEFI.
Thanks!

Hi carolyuu,

Thank you for the information.
Firstly, I need to know whether it worked well with the bmp file we shared here.
So, could you please answer for it?

thanks

Hi A_Y,

Yes, it’s working with you attached bmp file on our side.

1 Like

Hi,

I am facing a similar issue with XAVIER NX.
As opposed to A_Y, I am using a docker environment for build.

Even though the new bmp files have been added to Assets folder and NVIDIA.fvmain.fdf.inc modified accordingly, logo was not changed.

The generated UEFI image is always the same size 2.7MB.