CVE-2023-48795 ssh terrapin vulnerability

On one of our customers we have an on premises 3.1.0 dls server.

Would upgrading to 3.2.0 patch this vulnerability? I do not see anything about it in the release notes.