D3D10 API libraries NOT found on..

Hi. Many of the cuda samples work. But the VFlockingD3D10.exe simulation of a flock of birds exits with the following error:
v5.5\Bin\win64\Release\VFlockingD3D10.exe"
VFlockingD3D10 Starting…

Found 1 CUDA Capable Device(s)
GPU 0: Quadro K1000M
D3D10 API libraries NOT found on… Exiting.
I got a blue screen the first time I installed the 900 MB cuda 5.5 SDK, right after the driver update. I went back and “finished” the install of the video driver and the two items following. But I still get this error.

Is D3D10 a DLL that windows is supposed to have, or should have come with the CUDA kit?
My config: Win7 64 SP1 Quadro K1000M. The CUDA tools say my Quadro is capable 3.0, but the NV CUDA capable GPUs page doesn’t list the K1000M as capable. Thanks!

All components but Nsight Visual Studio Edition 3.1 show same “New Version” and “Current Version”. Nsight shows new version 3.1, and current version “Not Available”. After I reinstalled, everything shows current. I have MS VisStud 2012 Pro.

I try to build this project in MSVS 2012, and find that it uses D3DX9.h and D3DX10.h, which it can’t find anywhere on the PC. I have a few DLLs by those names in system32 (e.g., D3DX9_43.DLL), but I don’t know where the header files are. Am I supposed to have DirectX SDK? I have “.\Windows Kits\8.0”, which has D3D9.h and D3D10.h without “X”. If I need the SDK, is version 9.29.1962 adequate?

The install problems were fixed by re-running install (CUDA SDK).
Both runtime and compile problems were fixed by installing version 9.29.1962 of DirectX SDK.
The header files are in C:\Program Files (x86)\Microsoft DirectX SDK (June 2010)\Include.

Problem solved.