Dd: writing to '/dev/loop1p1': No space left on device when creating an image

I’m building an image with L4T for the jetson nano 4GB. and when I run ./jetson-disk-image-creator.sh to build the image I got this error

127116 bytes (127 kB, 124 KiB) copied, 0.000164705 s, 772 MB/s
jetson-disk-image-creator.sh - writing /build/Linux_for_Tegra/bootloader/system.img.raw
dd: writing to '/dev/loop1p1': No space left on device

I run this scripts inside a container (docker or podman both have the same error) with all the necessary permissions. here is an example

docker run \
	--user root \
	--device-cgroup-rule="b 7:* rwm" \
	--device /dev/loop-control:/dev/loop-control:rwm \
	--privileged \
	--cap-add=all \
	--rm \
	-it \

It’s not a permission issue cause I can fully manage loop devices inside the conainer.

There was a similar issue before here but it does not solve it.

Any help would be appreciated,

This means your host PC is out of disk space. Typically you would look at the result of “df -H -T .” after you cd to the “Linux_for_Tegra/” directory. That raw partition is quite large, and then the sparse partition is many GB beyond that.

If everything is installed on the host PC with an ext4 partition, then I’d hope you still have at least 50 GB left before starting the flash. The SD card models will differ somewhat compared to eMMC.

Nope, it’s not space. I have enough space. here is the proof

➜  df -h
Filesystem              Size  Used Avail Use% Mounted on
dev                      16G     0   16G   0% /dev
run                      16G  1.7M   16G   1% /run
/dev/mapper/crypt_disk  954G  881G   71G  93% /
tmpfs                    16G  128M   16G   1% /dev/shm
tmpfs                    16G   13M   16G   1% /tmp
/dev/nvme0n1p1          500M  380K  499M   1% /efi
/dev/mapper/home-mike   728G  304G  422G  42% /home/mike
tmpfs                   3.2G   64K  3.2G   1% /run/user/60475

Please check this topic and give it a try:
create-jetson-nano-sd-card-image.sh fails with no space left on device while creating image

I found the solution in this repo GitHub - pythops/jetson-nano-image: Create a minimalist, Ubuntu based image for Nvidia jetson nano board. Thanks for your answers

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.