Deadlock when initializing OmiKitHelper, failing to use SyntheticDataHelper

Hi!

I would like to use the synthetic data generation capabilities of Isaac to generate labeled visual data from a custom .usd file.
I wanted to start by modifying the demo script provided in python_samples/syntheticdata/basic/demo.py; but I keep getting into deadlocks in line 32. In the terminal, this throws the following error:
2021-04-14 04:12:40 [152,709ms] [Error] [carb.python] omni.kit.window.stats-0.1.0 -> <class 'omni.kit.window.stats.stats_window.Extension'>: extension object is still alive, something holds a reference on it. Referenced by: ["[0]:type: <class 'frame'>, id: 140391999646280", "[1]:type: <class 'method'>, id: 140396979873864"]

If no deadlock occurs, I still fail to obtain the ground throuth images, as SyntheticDataHelper.get_groundtruth() returns None in line 62. The mesh generation seems to run fine. I am using Ubuntu 18.04.

Could you help in finding a fix to this?
Thanks a lot!

Can you please attach the full log/output in the terminal?
Can you also try running simple/time_stepping.py?
This is the most basic sample to run and should help figure out whats going on.

Thanks a lot for your swift answer! It seems that time_stepping.py throws a similar error; here is the full log after running it:
[0.000s] [ext: omni.assetimport] shutdown
[0.000s] [ext: omni.utils.movie_capture] shutdown
[0.000s] [ext: omni.utils.collect_tool] shutdown
[0.000s] [ext: omni.utils.utilities_menu] shutdown
[0.001s] [ext: omni.kit.builtin.test_runner] shutdown
[0.001s] [ext: omni.kit.builtin.render_settings_window] shutdown
[0.003s] [ext: omni.kit.builtin.provide_feedback_window] shutdown
[0.003s] [ext: omni.kit.builtin.profiler] shutdown
[0.003s] [ext: omni.kit.builtin.preferences_window] shutdown
[0.004s] [ext: omni.kit.builtin.menu] shutdown
[0.004s] [ext: omni.kit.builtin.material_library] shutdown
[0.004s] [ext: omni.kit.builtin.init] shutdown
[0.004s] [ext: omni.kit.builtin.file_menu] shutdown
[0.004s] [ext: omni.kit.builtin.extensions_manager_window] shutdown
[0.005s] [ext: omni.kit.builtin.audio_settings_window] shutdown
[0.005s] [ext: omni.kit.builtin.audio_player_window] shutdown
[0.907s] [ext: omni.kit.widget.live-0.1.0] shutdown
[0.908s] [ext: omni.kit.window.stats-0.1.0] shutdown
2021-04-14 11:45:07 [49,934ms] [Error] [carb.python] omni.kit.window.stats-0.1.0 → <class ‘omni.kit.window.stats.stats_window.Extension’>: extension object is still alive, something holds a reference on it. Referenced by:
["[0]:type: <class ‘frame’>, id: 140107819718728", “[1]:type: <class ‘method’>, id: 140115255683208”]
[0.915s] [ext: omni.kit.window.details-0.1.0] shutdown
[0.916s] [ext: omni.kit.widget.layers-0.1.0] shutdown
[0.917s] [ext: omni.isaac.urdf] shutdown
[0.918s] [ext: omni.isaac.step_importer] shutdown
[0.918s] [ext: omni.isaac.samples] shutdown
[1.040s] [ext: omni.isaac.utils] shutdown
[1.099s] [ext: omni.isaac.synthetic_utils] shutdown
[1.099s] [ext: omni.isaac.robot_engine_bridge] shutdown
[1.100s] [ext: omni.syntheticdata] shutdown
[1.100s] [ext: omni.kit.window.console-0.1.0] shutdown
[1.101s] [ext: omni.kit.widget.stage-0.1.0] shutdown
[1.101s] [ext: omni.kit.context_menu-0.1.0] shutdown
[1.102s] [ext: omni.kit.window.content-0.1.0] shutdown
[1.102s] [ext: omni.kit.window.toolbar-0.1.0] shutdown
[1.103s] [ext: omni.physx.ui] shutdown
[1.103s] [ext: omni.isaac.dr] shutdown
[1.104s] [ext: omni.isaac.motion_planning] shutdown
[1.104s] [ext: omni.isaac.dynamic_control] shutdown
[1.120s] [ext: omni.isaac.lidar] shutdown
[1.121s] [ext: omni.physx] shutdown
[1.181s] [ext: omni.kit.window.viewport-0.1.0] shutdown
[1.181s] [ext: omni.kit.default-0.1] shutdown
[1.181s] [ext: omni.kit.window.tagging-0.1.0] shutdown
[1.181s] [ext: omni.tagging-0.1.0] shutdown
[1.182s] [ext: omni.kit.window.usd_paths-0.1.0] shutdown
[1.182s] [ext: omni.kit.window.script_editor-0.1.0] shutdown
[1.182s] [ext: omni.kit.primitive.mesh-0.1.0] shutdown
[1.182s] [ext: omni.convexdecomposition] shutdown
[1.182s] [ext: omni.debugdraw] shutdown
[1.183s] [ext: omni.kit.stage_templates-0.1] shutdown
[1.183s] [ext: omni.isaac.manip] shutdown
[1.183s] [ext: omni.isaac.about] shutdown
[1.184s] [ext: omni.kit.editor-0.1.0-full] shutdown

Hi all!

The problem was solved by reinstalling, just in case someone encounters the same.

Thank you bforrai.

Kindly,
Liila