Debugger Doesn't work with Qt app

Hi All,

I’m openinig up the debugger and wanting to launch an app that uses Qt (who’s version seems to be different to the one the dedbugger is using).

I get

symbol qt_version_tag, version Qt_5.7 not defined in file libQt5Core.so.5 with link time reference

Anyone know what I can prepend before running the debugger to make it work?

Hi tomkulaga,

I believe LGD is using Qt 5.5.
Can you try to launch the app from command line then attach it with LGD?

  1. open LGD and install debugger
  2. in command line

    LD_PRELOAD=~/.tgd/libs/libNvidia_gfx_debugger.so

  3. in LGD, connect -> attach tab -> select your app process -> attach