Debugger in PGI Community Edition Version 17.10

I am using CODE::BLOCKS v-16.01 svn 11210 with the Fortran Project Plugin v-1.5 on my 64 bit Debian 9 Linux platform.

The Debugger GUI opened once the first time I tried it, bu not it throws an error:

pgdbg-Warning-Unable to verify Java version using /usr/bin/java.
The minimum required version is 1.6.0_21. If you are
using an older version of Java you may encounter errors
or unexpected behavior.
Segmentation fault

I have jdk and jre v-9.0.1 goth installed in /usr/lib/jvm.

What am I missing, or alternately, failing to see.

Thanks in advance

Stephen P. Molnar, Ph.D. Life is a fuzzy set
www.molecular-modeling.net Stochastic and multivariate
(614)312-7528 ©
Skype: smolnar1

You can direct the debugger and profiler to use a particular
version of java via PGI_JAVA. For example, if the java executable
is /usr/lib/jvm/bin/java

export PGI_JAVA=/usr/lib/jvm/bin/java

and then run pgdbg.

Whether the version of java you have is enough to work, we are
not sure.

dave

Thanks for the, this worked. However the solution generated the message:

comp@AbNormal:/opt/pgi/linux86-64/17.10/bin$ ./pgdbg
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by com.jidesoft.swing.JideTabbedPane (file:/opt/pgi/linux86-64/17.10/bin/jide-common.jar) to field javax.swing.JTabbedPane.visComp
WARNING: Please consider reporting this to the maintainers of com.jidesoft.swing.JideTabbedPane
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release

Please determine if the problem is the User Interface/Java or not by
running pgdbg in text mode.

pgf90 -o foo foo.f90 -g

pgdbg -text foo

and see if command line debugging works.

dave