Debugging an Existing APK gets error: Precondition failed: activity != null

I just installed Visual Studio 2013 Pro and all the components of tadp. I recompiled our apk using the version of the android sdk and ndk installed by tadp. It installs and runs on our Shield ok. The build process is a bit complicated, so to start with I just want to try debugging it with visual studio. I followed the instructions under Debugging an Existing APK on http://docs.nvidia.com/tegra/Content/Nsight_Tegra_Debugging.htm

When I click Start Debugging it copies to the Shield ok, but then the Launching application has a red X next to it and at the top it says: Precondition failed: activity != null

I tried both copying the AndroidManifest.xml from our project to the HelloWorld project, and I tried just editing the package and activity android:name in the generated AndroidManifest.xml to match ours. Both had the same results.

I also tested debugging a fresh Hello World project with no modifications and it worked ok.

Any ideas on what could be wrong and where to go from here?

this is known issue, We have fixed it, it would be at the next release.
there is a workaround by avoid whitespace in your android:label .

That was it, thank you.