Deep Reinforcement Learning in Robotics --> Cmake Errors with Qt versions

Using Jetson Nano Orin Dev Kit to follow https://github.com/dusty-nv/jetson-reinforcement
Seeing the below errors related to Qt versions when running CMakeLists.txt

Any solutions to fix this?

qmake --version
QMake version 3.1
Using Qt version 5.12.8 in /usr/lib/aarch64-linux-gnu

Cmake errors

-- Copying /home/myx3ds/Desktop/jetson-reinforcement/python/test-torch.py
-- Found Boost: /usr/lib/aarch64-linux-gnu/cmake/Boost-1.71.0/BoostConfig.cmake (found version "1.71.0") found components: system 
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.29.1") 
-- Checking for module 'gazebo'
--   No package 'gazebo' found
-- jetson-utils:  building as submodule, /home/myx3ds/Desktop/jetson-reinforcement
CMake Error at /usr/share/cmake-3.16/Modules/FindQt4.cmake:1314 (message):
  Found unsuitable Qt version "5.12.8" from /usr/bin/qmake, this code
  requires Qt 4.x
Call Stack (most recent call first):
  utils/CMakeLists.txt:12 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/myx3ds/Desktop/jetson-reinforcement/build/CMakeFiles/CMakeOutput.log".
See also "/home/myx3ds/Desktop/jetson-reinforcement/build/CMakeFiles/CMakeError.log".

Hi @cedricyangks, sorry as noted at the top of that readme, that project was for older JetPack on previous Ubuntu version, and has been inactive for several years. You could try installing qt4 somehow if that’s possible, but you’d likely encounter other issues such as the older PyTorch version it requires.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.