Deep stream 5.0 LPR application not compiling


I am trying to test : GitHub - NVIDIA-AI-IOT/deepstream_lpr_app: Sample app code for LPR deployment on DeepStream
On Jetson Xavier NX, with system info :
NVIDIA Jetson Xavier NX (Developer Kit Version)
L4T 32.5.1 [ JetPack UNKNOWN ]
Ubuntu 18.04.5 LTS
Kernel Version: 4.9.201-tegra
CUDA 10.2.89
CUDA Architecture: 7.2
OpenCV version: 4.1.1
OpenCV Cuda: NO
Vision Works:
VPI: ii libnvvpi1 1.0.15 arm64 NVIDIA Vision Programming Interface library

I have installed and tested :
Deepstream 5.1
And while compiling : make -C nvinfer_custom_lpr_parser
g++ -c -o deepstream_lpr_app.o -fpermissive -Wall -Werror -DPLATFORM_TEGRA -I/opt/nvidia/deepstream/deepstream/sources/includes pkg-config --cflags gstreamer-1.0 -D_GLIBCXX_USE_CXX11_ABI=1 deepstream_lpr_app.c

error1 :
deepstream_lpr_app.c:31:10: fatal error: gstnvdsmeta.h: No such file or directory
#include “gstnvdsmeta.h”

also error 2: make -C nvinfer_custom_lpr_parser
g++ -o nvinfer_custom_lpr_parser.cpp -Wall -Werror -std=c++11 -shared -fPIC -Wno-error=deprecated-declarations -I/opt/nvidia/deepstream/deepstream/sources/includes -Wl,–start-group -lnvinfer -lnvparsers -Wl,–end-group

nvinfer_custom_lpr_parser.cpp:31:10: fatal error: nvdsinfer.h: No such file or directory
#include “nvdsinfer.h”

Is there any version mismach.
or LIBRARY_PATH needs to be added ?

You need to correct the path deepstream_lpr_app/Makefile at master · NVIDIA-AI-IOT/deepstream_lpr_app · GitHub to make the compiler find the header files

Yes, its the same thing I tried.
I changed the directory as below in the makefile :
CFLAGS+= -I/opt/nvidia/deepstream/deepstream-5.1/sources/includes

Since the deepstream folder I obtained was deepstream-5.1/
But still on make clean and make I was getting same error.
Are there any multiple places where this change has to be done ?
And can you suggest why the -lnvinfer is used in Makefile and how it links to nvdsinfer.h file (because its already present and unidentifiied ) ?

Thanks for the responce.

Can you share the error log?

Hi @bcao

The issue with compilation is solved.
I used Deepstream SDK 5.1 now with released SD card imge for Xavier Nx.

Im trying to run a custom input.mp4 with H264 format as suggested as :
./deepstream-lpr-app 1 3 0 input.mp4 output.mp4

log obtained :
One element could not be created. Exiting.

  1. Is there any way to solve this issue :
    (As per the source : deepstream_lpr_app.c line 482 , its an issue with GST streammux.)

  2. Also is there a way to detect license plate while capturing/streaming the video ?

Thanks for any help on this…

Hey, could you create a new topic for your new issue, we would like one topic to track one issue.

Ya definitely.

Thanks, so we can close this topic and track your new issue in that topic.

Please find the topic created here :