[Deepin 15.4.1+nvidia driver 375.26] Boot splash screen lost after installing nvidia drivers


can anyone at least explain to me, why after installing nvidia drivers from the deepin’s system driver manager (version 375.26) the beautifull deepin boot splash animation is getting subtituted by an ugly, low res animation of three white squares in the middle of grey screen?
Is this a driver issue, system issue, grub2 issue or any combination of those?

Many users over Internet complain about this bug in different ditros - all after installing the proprietary drivers and no one can provide a clear answer what is the cause.

Seems like my grub config is completely ignored - changes made here do nothing.

# Written by com.deepin.daemon.Grub2
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
GRUB_DISTRIBUTOR="`/usr/bin/lsb_release -d -s 2>/dev/null || echo Deepin`"

Here are my specs:

System:    Host: linuxlab3 Kernel: 4.9.0-deepin9-amd64 x86_64 (64 bit gcc: 6.3.0)
           Desktop: Gnome  (Gtk 3.22.11-1) Distro: Deepin 15
Machine:   Device: desktop Mobo: ASUSTeK model: Z170-DELUXE v: Rev 1.xx
           UEFI [Legacy]: American Megatrends v: 1902 date: 06/27/2016
CPU:       Quad core Intel Core i7-6700K (-HT-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 32064
           clock speeds: max: 4001 MHz 1: 800 MHz 2: 800 MHz 3: 800 MHz 4: 800 MHz 5: 800 MHz 6: 800 MHz
           7: 800 MHz 8: 800 MHz
Graphics:  Card: NVIDIA GP104 [GeForce GTX 1080] bus-ID: 01:00.0
           Display Server: X.Org 1.19.3 driver: nvidia Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce GTX 1080/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 375.26 Direct Rendering: Yes
Audio:     Card-1 NVIDIA GP104 High Definition Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel Sunrise Point-H HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.9.0-deepin9-amd64
Network:   Card-1: Intel Ethernet Connection (2) I219-V driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
           IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Broadcom Limited BCM4360 802.11ac Wireless Network Adapter driver: wl bus-ID: 07:00.0
           IF: wlp7s0 state: dormant mac: <filter>
           Card-3: Intel I211 Gigabit Network Connection driver: igb v: 5.4.0-k port: c000 bus-ID: 0b:00.0
           IF: enp11s0 state: down mac: <filter>
Drives:    HDD Total Size: 2520.5GB (3.3% used)
           ID-1: /dev/sda model: Samsung_SSD_850 size: 256.1GB
           ID-2: /dev/sdb model: Samsung_SSD_850 size: 1024.2GB
           ID-3: /dev/sdc model: WDC_WD1002FAEX size: 1000.2GB
           ID-4: /dev/sdd model: KINGSTON_SH100S3 size: 120.0GB
           ID-5: /dev/sde model: KINGSTON_SV300S3 size: 120.0GB
Partition: ID-1: / size: 110G used: 79G (76%) fs: ext4 dev: /dev/sdd1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:41C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 225 Uptime: 1:57 Memory: 3024.0/32094.5MB Init: systemd runlevel: 5 Gcc sys: 6.3.0
           Client: Shell (bash 4.4.111) inxi: 2.3.5

Any help highly appreciated.
If more info is needed - just ask - I’ll provide.

It’s not a bug, it’s a feature.
That nice animation needs a KMS framebuffer, which nvidia does not provide.

Is there any workaround for this or this is simply dead end?

On Linux Mint 18.2 I managed to display the system’s boot animation simply by changing the resolution to 1920x1080 in grub settings although nvidia drivers are also installed. After selecting the system in grub, the LM logo with dots appears for a second, then for a fraction of a second three dots on black screen appear (most probably where the nvidia drivers are being loaded) and then I’m in my login screen.

I don’t understand why settings from Deepin grub config are being totally ignored…
Has it something to do with the fact, that I have two Linux distros? It’s not dual boot though - every system has its own, dedicated SSD. My main grub is on Linux Mint’s drive - from here I can launch 3 systems - mint, deepin and windows. Linux Mint grub is in 1920x1080. Once I launch Deepin I can see that resolution has changed to lower one.
Can I perhaps somehow define in Mint’s grub config how Deepin is launched?