DeepSORT ReID is not working in DeepStream6.1

Please provide complete information as applicable to your setup.

Hardware Platform ( GPU)
DeepStream Version: 6.1
TensorRT Version:8.2
NVIDIA GPU Driver Version (valid for GPU only):cuda 11.6
Issue Type( questions, new requirements, bugs):questions
• hi, I am trying to run a resnet34 person object-detection + deepsort tracking pipeline using the deepstream6.1, all models are official cases by default,but the person id ,frequently changed when short occlusions,the demo results like this:

and the source video for you can reproduce it:

the config is samples/configs/deepstream-app/source4_1080p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt with few modifications:
source4_1080p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt (5.7 KB)
the config-file of [primary-gie] is here,and the model use nvidia resnet34 peoplenet model
config_infer_primary_person.txt (2.3 KB)

and convert the deepsort’s reid model is fellow the ./sources/tracker_DeepSORT/README,
the config_tracker_DeepSORT.yml no changed :
config_tracker_DeepSORT.yml (5.0 KB)

this is my command line:deepstream-app -c /opt/nvidia/deepstream/deepstream-6.1/samples/configs/deepstream-app/source4_1080p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt

and this is the info in my terminal:
terminal_info.txt (98.9 KB)

Restatement of problem,It is obvious that the deepsort should have a better performance, and not keep changing ids because of short occlusion or disappearing , please help me, Thanks!

I am try to reproduce your result in my side in this topic. But I can reproduce your result. Can you share your command line as the question in below topic?

his topic was automatically closed 14 days after the last reply. replies are no longer allowed. so I just recreate this theme

OK. Please share the reproduce step to reproduce below result. Thanks. I have tried it previously, but I found the tracker ID change frequently.

" I filtered out all the other classes from the yolo model other than humans by using the yolov5 _crowdhuman weights and passing the argument --classes 0 while running the script. The reid model used was Osnet_x1_0 model trained on MSMT 17 dataset ."

I’m sorry, I don’t know how he used the other model to verify this problem, I just used the default model mars-small128.uff and no change the REID parameters, took his video and my video, and I found the tracker ID change frequently, It gives me the impression that the result is SORT algorithm, not DeepSort。 Now that you’ve reproduced the problem, can you see what the problem is? thanks!

Below topic shared the same video as yours. Below topic show DeepSORT can get very good result in: GitHub - mikel-brostrom/Yolov5_StrongSORT_OSNet at v5.0 . I plan to check it. But I don’t get response from that topic. Do you know the user who submit below topic? Can you help to ask the user response?

in order to get better resistance to occlusion, i try deepsort in deepstream6.1, but found the tracker ID change frequently ,i find the same topic in the blog, he thinks the problem cause by the model,so he try other model. but the problem is still there, so may be it’s the bug in deepstream6.1,i donot konw he, I failed to contact him, sorry,
you can try to solve the problem of the reproduced, maybe you can solve the problem of me and him!

你好,可以分享一下deepsort官方pb文件转后的uff文件吗?我自己转换一直出问题

Can you submit one new topic? Thanks.

Hi, I am also having the same problem. I tried the default model mars-small128.uff and the model Osnet_x1_0 trained on the MSMT 17 dataset and found that the tracker ID changes frequently. I will follow the updates to solve this problem.

1 Like