Deepsream python: Encoder Error

Hello
I recently installed deepstream 5.0 and python binding.
I tried to run the deepstream_ssd_parser, but I got this message:


Creating Encoder
Unable to create Encoder
If the following error is encountered:
/usr/lib/aarch64-linux-gnu/libgomp.so.1: cannot allocate memory in static TLS block
Preload the offending library:
export LD_PRELOAD=/usr/lib/aarch64-linux-gnu/libgomp.so.1
Traceback (most recent call last):
File “deepstream_ssd_parser.py”, line 458, in
sys.exit(main(sys.argv))
File “deepstream_ssd_parser.py”, line 363, in main
encoder.set_property(“bitrate”, 2000000)
AttributeError: ‘NoneType’ object has no attribute ‘set_property’

I appreciate it if anyone can help me to solve it.
Thanks

Hi,
I believe this is your setup issue. Please provide your setup info like below?

• Hardware Platform: NVIDIA T4
• DeepStream Version: 5.0
• TensorRT Version: 7
• NVIDIA GPU Driver Version 440

Hi
Fortunately, I fixed it.
Many thanks

1 Like

How did you fixed it ? I am the samme issue. please Help me

1 Like

can you tell us how did you fix it?

I still face the same problem. can you help me please