DeepStream 4.0.1 for Jetson TX2

i tried to install deepstream 4.0.1 deb package
but i got this message :
The following packages have unmet dependencies:
deepstream-4.0 : Depends: libnvinfer5 (>= 5.1.2) but it is not installable
E: Unable to correct problems, you have held broken packages.

so i tried tar package
when i run:
deepstream-app --help
i get that message
deepstream-app: error while loading shared libraries: cannot open shared object file: No such file or directory

when i run dpkg -l | grep nvinfer
i get :
ii libnvinfer-bin 6.0.1-1+cuda10.0 arm64 TensorRT binaries
ii libnvinfer-dev 6.0.1-1+cuda10.0 arm64 TensorRT development libraries and headers
ii libnvinfer-doc 6.0.1-1+cuda10.0 all TensorRT documentation
ii libnvinfer-plugin-dev 6.0.1-1+cuda10.0 arm64 TensorRT plugin libraries
ii libnvinfer-plugin6 6.0.1-1+cuda10.0 arm64 TensorRT plugin libraries
ii libnvinfer-samples 6.0.1-1+cuda10.0 all TensorRT samples
ii libnvinfer6 6.0.1-1+cuda10.0 arm64 TensorRT runtime libraries
ii python-libnvinfer 6.0.1-1+cuda10.0 arm64 Python bindings for TensorRT
ii python-libnvinfer-dev 6.0.1-1+cuda10.0 arm64 Python development package for TensorRT
ii python3-libnvinfer 6.0.1-1+cuda10.0 arm64 Python 3 bindings for TensorRT
ii python3-libnvinfer-dev 6.0.1-1+cuda10.0 arm64 Python 3 development package for TensorRT

i have
JetPack 4.3
TensorRT 6.0.1
Cuda 10.0

Solved by installing deepstream 4.0.2 instead of 4.0.1 because it works with JetPack 4.3