Deepstream 5.1 SDK Segmentation fault (core dumped) with add-del + rtsp-out

• DeepStream Version = 5.1
• NVIDIA GPU Driver Version - CUDA = 11.1

I am using the following add_del_multisources with 4 rtsp sources and have set streamdemux to sink 4 individual rtsp-out servers.

This custom pipeline:

This used to working in docker = 5.1-21.02-devel but now I get an error:

Please suggest any solutions!

What do you mean? Do you mean c/c++ sample works but python sample failed?

I’m running c/c++ compiler based on c/c++ samples add_del_sources. I’ve customized it.

Do you think the failure is caused by deepstream by not what you changed?

I run successful without streamdemux but not with added streamdemux .

There is nvstreammux in the sample. Please check your code to find out what is the difference and why the error happens.

Yes, I did.
Can you check my pipeline?
deepstream_muxe.c (5.3 KB)

I solved the error "Segmentation fault (core dumped). But I’m now facing to unable read rtsp-out server. In this pipeline, I enter source_id and uri value from keyboard.

streammux → nvvidconv → nvosd → streamdemux → udpsink_bin

queue → nvvidconv → cap-filter(“video/x-raw, format=I420”) —> encoder(nvv4l2h264enc) → rtppay → sink (“udpsink”)

This my code
deepstream_custom_add_del_2.c (18.5 KB)

While processing add_del

Please suggest any solution!

Did this still be an issue?

Thanks your response.
I’ve not resolved this problem, I’ve a break from other work.
Please suggest any solution

At a first glance, you did not connect streammux and source.

I worked add_del custom + save filesink ( my issue, I just custom filesink → udpsink ).

After the first step add-source, I get link streammux and source at main . Other steps, when adding a source from the keyboard, I use function add_sources which has get_request_pad (streammux, pad_name ).

This my update code
deepstream_custom_add_del_rtsp.c (20.2 KB)

You still did not connect nvstreammux with source, the element before it, You can refer to any sample about this.

Thanks for your response, I can resolve my problem which is rtsp-out error.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.