DeepStream 6.1.1 support for JetPack 5.0.2

Please provide complete information as applicable to your setup.

Hardware Platform Xavier AGX
DeepStream Version 6.1.1
JetPack Version 5.0.2

Try to install DeepStream 6.1.1 for Jetpack 5.0.2 on AGX, using the Quickstart Guide.
https://docs.nvidia.com/metropolis/deepstream/6.1.1/dev-guide/text/DS_Quickstart.html

In the Install latest NVIDIA BSP packages the guide tells me to make the following changes to the nvidia-l4t-apt-source.list

deb https://repo.download.nvidia.com/jetson/common r35.1 main
deb https://repo.download.nvidia.com/jetson/t194 r35.1 main
Note:
It originally pointed to r35.2

sudo apt update
sudo apt install --reinstall nvidia-l4t-gstreamer
Reading package lists… Done
Building dependency tree
Reading state information… Done
Reinstallation of nvidia-l4t-gstreamer is not possible, it cannot be downloaded.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Any help you can supply would be greatly appreciated.

r35.2 is for JP5.1 and the corresponding version of DeepStream is 6.2.
Are you sure the Jetpack version is 5.0.2?
You can check the file “/etc/nv_tegra_release” for BSP version, if REVISION is V2.1, then it is JP5.1.

1 Like

I appreciate the quick response you are correct I’m JetPack 5.1 (L4T 35.2.1). My apologies for not checking on that first. I will close the issue and thank you again for your help

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.