DeepStream 6.2 Upgrade Issues on Jetson Xavier NX: Argus Camera Socket Errors

I have tried replacing all 4 cameras and their wiring with completely new components, with no satisfactory results. I have tried replacing the Jetson NX with a completely new one. Definitely not a hardware problem. I have also tried hybrid things like flashing a NX with JP 5.1.1 and use the e l4t-multimedia package from L4T r35.4.1, without success.

Also tried to boost the clocks:

sudo su
echo 1 > /sys/kernel/debug/bpmp/debug/clk/vi/mrq_rate_locked
echo 1 > /sys/kernel/debug/bpmp/debug/clk/isp/mrq_rate_locked
echo 1 > /sys/kernel/debug/bpmp/debug/clk/nvcsi/mrq_rate_locked
echo 1 > /sys/kernel/debug/bpmp/debug/clk/emc/mrq_rate_locked
cat /sys/kernel/debug/bpmp/debug/clk/vi/max_rate |tee /sys/kernel/debug/bpmp/debug/clk/vi/rate
cat /sys/kernel/debug/bpmp/debug/clk/isp/max_rate | tee  /sys/kernel/debug/bpmp/debug/clk/isp/rate
cat /sys/kernel/debug/bpmp/debug/clk/nvcsi/max_rate | tee /sys/kernel/debug/bpmp/debug/clk/nvcsi/rate
cat /sys/kernel/debug/bpmp/debug/clk/emc/max_rate | tee /sys/kernel/debug/bpmp/debug/clk/emc/rate

It also did not solve the problem.

But I finally found something that at least looks like the solution!
I found in a post a libnvargus.so library modified by a moderator for my version of Jetpack 5.1.1. After replacing it with this one, I’m running tests and my pipeline has been running for about 24h without interruptions!
Yo can find the libnvargus.so here.

It seems that this was the problem!