Deepstream-app can only be run under normal users?

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
Jetson Xavier NX
• DeepStream Version
Deepstream 5.0
• JetPack Version (valid for Jetson only)
JetPack 4.4
• TensorRT Version
TensorRT 7.1.3
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)
I want to automatically start Xavier Nx and run a series of scripts, but I found that deepstream-app can only be run under normal users, while other scripts need to be run under root users. How should I set deepstream-app to run under the root user.
Thank you!

Have you chown the onwer of deepstream-app to root and see if the issue persist?

I have tried to give ownership of deepstream-app to root user,The system prompts as follows:

** ERROR: <create_multi_source_bin:1057>: Failed to create element ‘src_bin_muxer’
** ERROR: <create_multi_source_bin:1132>: create_multi_source_bin failed
** ERROR: <create_pipeline:1304>: create_pipeline failed
** ERROR: main:640: Failed to create pipeline
App run failed

But,deepstream-app runs normally under normal users.
any idea?thanks.

Can you share the script with us?

You mean run the script as normal user?

Can you try clear the cache: rm -rf ~/.cache/gstreamer-1.0/registry.aarch64.bin
and then using sudo gst-inspect-1.0 to check the info

I finally solved this problem. I changed the permission of other scripts to normal users. Thank you for your reply.