Deepstream app produces process ID in the format of millions 2684485

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
AGX Orin
• DeepStream Version
7.0
• JetPack Version (valid for Jetson only)
JP6
• TensorRT Version

• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Hi,

I run the AGX Orin with deepstream and three cameras.
Inference is passed to the osd_sink_pad_buffer_probe where I store the image and metadata as
Pascal/VOC meta data xml file.

Why do I have such high process ID number? Running ps -a I see that it increments alot. The python script has ID: 2684485
That does not make sense?

Any ideas?

This is just a randomly assigned process number. How does this process number affect the program?

Hi,

The number does not affect my program. My assumption is that every time there is a new process there is a new process ID. My question is, why does my Deepstream python script produce so many high numbers? It feels like Deepstream produces a new process ID every time it detects an error and it for some reason shows the python script I run with a new process ID. It is very strange that the number is so high, unless I have restarted the python script many hundreds of times (which I have not).
Normally also you get a process ID close to 4000 roughly or at least <20000. This is 2’000’000?

You can check the pid_max through sudo cat /proc/sys/kernel/pid_max. It could be that your machine is running all the time and running too many programs during this time.

hi.
ps -a shows:

PID TTY TIME CMD
2612 tty2 01:25:32 Xorg
2621 tty2 00:00:00 gnome-session-b
105374 pts/0 00:29:00 python3
105552 pts/3 00:00:00 ps

as you see the PID ID is very high.

sudo cat /proc/sys/kernel/pid_max
4194304

Why would it be so high? Its like the Deepstream is creating new PIDS for every inference or something? Its very strange behavior

As you can see when you ran the python command, it only had one process. Because this doesn’t have any effect on you program, you can just ignore that.

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks