Deepstream-app RTSP sink error

I try to set RTSP sink to put out,but it failed.The log is " gst_element_get_static_pad: assertion 'GST_IS_ELEMENT (element)". I have installed libgstrtspserver-1.0 and modify config many times.
config:
//---------------------------------------
[application]
enable-perf-measurement=1
perf-measurement-interval-sec=5
#gie-kitti-output-dir=streamscl

[tiled-display]
enable=0
rows=1
columns=2
width=1920
height=768
#width=800
#height=600
gpu-id=0
#(0): nvbuf-mem-default - Default memory allocated, specific to particular platform
#(1): nvbuf-mem-cuda-pinned - Allocate Pinned/Host cuda memory, applicable for Tesla
#(2): nvbuf-mem-cuda-device - Allocate Device cuda memory, applicable for Tesla
#(3): nvbuf-mem-cuda-unified - Allocate Unified cuda memory, applicable for Tesla
#(4): nvbuf-mem-surface-array - Allocate Surface Array memory, applicable for Jetson
nvbuf-memory-type=0

[source0]
enable=0
#Type - 1=CameraV4L2 2=URI 3=MultiURI
type=3
#uri=file://…/…/samples/streams/sample_1080p_h264.mp4
#uri=file://…/myYOLO/1.mp4
#uri=rtmp://live.innno.net/test/jiance?auth_key=1951857692-0-0-6e0c986d4ae84971e76657e85e5d101d
uri=rtmp://live.innno.net/test/jiance_1?auth_key=1951857851-0-0-d9c49005cace966782c717f9d2cc7241
num-sources=1
gpu-id=0
cudadec-memtype=0

#[source1]
#enable=1
#Type - 1=CameraV4L2 2=URI 3=MultiURI
#type=3
#uri=rtmp://live.innno.net/test/jiance_1?auth_key=1951857851-0-0-d9c49005cace966782c717f9d2cc7241
#num-sources=1
#gpu-id=0
#cudadec-memtype=0

(0): memtype_device - Memory type Device

(1): memtype_pinned - Memory type Host Pinned

(2): memtype_unified - Memory type Unified

#cudadec-memtype=0

#[sink0]
#enable=0
#Type - 1=FakeSink 2=EglSink 3=File
#type=2
#sync=0
#source-id=0
#gpu-id=0
#nvbuf-memory-type=0

[sink0]
enable=0
#Type-1=FakeSink 2=EglSink 3=File 4=RTSPStreaming
type=4
container = 2
codec = 1
qos = 1
sync=0
source-id=0
gpu-id=0
#nvbuf-memory-type=0
bitrate = 4000
rtsp-port = 8554
width = 800
height = 600
udp-port = 5400

[osd]
enable=1
gpu-id=0
border-width=1
text-size=15
text-color=1;1;1;1;
text-bg-color=0.3;0.3;0.3;1
font=Serif
show-clock=0
clock-x-offset=800
clock-y-offset=820
clock-text-size=12
clock-color=1;0;0;0
nvbuf-memory-type=0

[streammux]
gpu-id=0
##Boolean property to inform muxer that sources are live
live-source=1
batch-size=2

##time out in usec, to wait after the first buffer is available
##to push the batch even if the complete batch is not formed
batched-push-timeout=400000

Set muxer output width and height

#width=1920
#height=1080
width=800
height=600
##Enable to maintain aspect ratio wrt source, and allow black borders, works
##along with width, height properties
enable-padding=0
nvbuf-memory-type=0
batch-size = 4

config-file property is mandatory for any gie section.

Other properties are optional and if set will override the properties set in

the infer config file.

[primary-gie]
enable=1
gpu-id=0
#model-engine-file=model_b1_gpu0_fp32.engine
labelfile-path=labels.txt
batch-size=2
#Required by the app for OSD, not a plugin property
bbox-border-color0=1;0;0;1
bbox-border-color1=0;1;1;1
bbox-border-color2=0;0;1;1
bbox-border-color3=0;1;0;1
interval=2
gie-unique-id=1
nvbuf-memory-type=0
config-file=config_infer_primary_yoloV3_tiny_innno.txt

[tracker]
enable=1
tracker-width=640
tracker-height=480
ll-lib-file=/opt/nvidia/deepstream/deepstream-5.0/lib/libnvds_mot_klt.so
enable-batch-process = 0

[tests]
file-loop=0

Hi,
Please share your device(Jetson platforms or desktop GPUs), and DS SDK version(4.0.2 or 5.0).

@DaneLLL Geforce TITAN XP DS5.0

Hi,
Please check you have executed dGPU Setup in
https://docs.nvidia.com/metropolis/deepstream/dev-guide/index.html

And try test-luanch:


See if you are able to launch

./test-launch "videotestsrc ! x264enc ! h264parse ! rtph264pay name=pay0 pt=96"

And

./test-launch "videotestsrc ! nvvideoconvert ! nvv4l2h264enc ! h264parse ! rtph264pay name=pay0 pt=96"

The bug is fixed,I think there is something wrong in sink config, I modify it. add codec = 1enc-type=0
[sink1]
enable=1
#Type - 1=FakeSink 2=EglSink 3=File
type=4
codec = 1
enc-type=0
sync=0
#source-id=1
gpu-id=0
#nvbuf-memory-type=0
bitrate = 1000000
rtsp-port = 8555
#width = 640
#height = 480
udp-port = 5401

1 Like