Deepstream error Failed to set buffer pool to active (1)

Hi am running the deepstream segmentation python app . This is the output I get:

I think this is because my Xavier is not connected to a monitor , I’m running the app through ssh on a docker container. I tried unsetting display , when I run the app with rtsp stream as input it says no file found “rtsp…”, if I pass in an image it says ran succesfully but no image is written in the output folder , now if i set DISPLAY=0, the above is the output for both rtsp stream and image . I’ve tried many solutions , using GNOME to shutoff display , but I am on a docker container so GNOME does not work , help me !!!

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

This demo need display environment. You can refer to the demo below to modify the code to save the output to a file.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.