Deepstream-image-meta-test

Hello,

I am struggling around to figure out how to run the deepstream-image-meta-test app.
I am working with Jetson TX2 and DS 5.0

I tried to run it with below command
"ubuntu@dhcp-10-24-142-103:/opt/nvidia/deepstream/deepstream-5.0/sources/apps/sample_apps/deepstream-image-meta-test$ ./deepstream-image-meta-test …/…/…/…/samples/streams/sample_720p.mp4
"
Facing this error -> ERROR from element uri-decode-bin: Invalid URI “…/…/…/…/samples/streams/sample_720p.mp4”.

Help would be appreciated!

./deepstream-image-meta-test file:///home/ubuntu/video1.mp4

1 Like

Thanks.

I could run the app but it is failing with a segmentation fault at
nvds_obj_enc_finish(ctx) in the pgie_src_pad_buffer_probe() of the deepstream_image_meta_test.c file

HI,
Did you make some changes? Is that possible to share for recreating your issue? or you could get the back trace after issue happened and paste here.

I haven’t done any change.
Can you help me with steps to generate the core dump for the backtrace.

Editing the Makefile to add the -g option and running the binary is not generating the core dump.
P.S - I have set the ulimit -c to unlimited. I have installed the gdb with apt-get tool.

Hope this link helps, http://www.fromdual.com/hunting-the-core.
or you could rm ~/.cache/gstreamer-1.0/ -rf and run the sample again, if issue still there, you could get the log by
GST_DEBUG=:level app > logname 2>&1

https://gstreamer.freedesktop.org/documentation/tutorials/basic/debugging-tools.html?gi-language=c

strangely, it worked after running the application as a super user

Glad to know.