DeepStream Installation Issues

Hi,

We are trying to build our app around DeepStream5.1. But recently we stumbled upon some versioning issues for libnvinfer and related packages while installing DeepStream5.1.

So, we decided to move to DeepStream6.0 and followed all the steps given in this Official Documentation: [ Quickstart Guide — DeepStream 6.0 Release documentation]

But now we are unable to use python-apps because some packages are missing inside the DeepStream folder. It seems like setup.py is also missing.

Steps followed by us are:

  1. Install necessary packages for DeepStream SDK
  2. Download and Install Cuda 11.4.1. This also took care of Nvidia Drivers
  3. Install TensorRT 8.0.1 for Ubuntu 18.04 and Cuda11.03 (this is exactly what the official documentation suggests)
  4. Installed DeepStream SDK through deb file as well as tar.

Machine Specs:

  1. Ubuntu 18.04
  2. Tesla T4 GPU
  3. It is a VM on AWS(g4dn.xlarge) [4vcpus, 16 GB RAM]

These are the 2 specific issues that we are facing:
DS5.1

  • when we tried installing python3-libnvinfer-dev package, we got conflicts with versions of already installed Cuda packages. We have not deviated from prescribed Documentation for given version of DS.

DS6.0

  • while completing setup for ds-python-apps, we were not able to find setup.py file as suggested by the prescribed Documentation.

As a result, we are not able to do a clean installation of DeepStream deterministically.
What steps should we take in order to make this run?

Can someone please help with this?

Hi @shantanu.bakare,

It seems to be related to some system dependencies or clean-up related.
Just wanted to check if you tried removing all previous DeepStream version from the system before installing DS 6.0 as mentioned in below doc:
https://docs.nvidia.com/metropolis/deepstream/dev-guide/text/DS_Quickstart.html#dgpu-setup-for-ubuntu

Also, best approach to avoid any system dependency is to use NGC containers.
Deepstream x86 NGC container:

Can you try running this container on your setup?

Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.