Deepstream on Jetpack 4.61 - Howto

I have a Jetson Nano B01. I am running Jetpack 4.61.
I am trying to install Deepstream 6 using the deepstream-6.0_6.0.1-1_arm64.deb file following the instructions at Deepstream 6.0.1 quickstart

I have checked that the correct version of jetpack is installed.

I have installed from a newly flashed SD card with Jetpack 4.61. and installed as above.

When I launch the command:
cdann@nano461:/opt/nvidia/deepstream/deepstream-6.0/samples/configs/deepstream-app$ deepstream-app -c source2_csi_usb_dec_infer_resnet_int8.txt
** ERROR: <create_multi_source_bin:1424>: Failed to create element ‘src_bin_muxer’
** ERROR: <create_multi_source_bin:1517>: create_multi_source_bin failed
** ERROR: <create_pipeline:1326>: create_pipeline failed
** ERROR: main:688: Failed to create pipeline

I have tried everything and I cannot get this to work. Any help would be greatly appreciated.

Kind regards
Chris Dann

Can you find nvstreammux?
gst-inspect-1.0 nvstreammux,
try to clean the cache, and try again, rm ~/.cache/gstreamer-1.0/registry.aarch64.bin

Hi @Amycao ,
Thank you for the reply - greatly appreciated.
I have just reinstalled using the deepsteam_sdk_v6.0.1_jetson.tbz2 tar ball. This worked.
I use an SSH terminal for convenience and sometimes forget that I am in an SSH terminal.
When I run :

cdann@nano461:/opt/nvidia/deepstream/deepstream-6.0/samples$ deepstream-app -c configs/deepstream-app/source2_csi_usb_dec_infer_resnet_int8.txt

I get →

No EGL Display
nvbufsurftransform: Could not get EGL display connection
cdann@nano461:/opt/nvidia/deepstream/deepstream-6.0/samples$ gst-inspect-1.0 nvstreammux
No EGL Display
nvbufsurftransform: Could not get EGL display connection

This is expected but it seems to corrupt the config and I continue to get the ‘src_bin_muxer’ error even from the GUI console.

If I rerun the sudo /opt/nvida/deepstream/deepstream-6.0/ script and sudo ldconfig and then run from the GUI console it works.

Thanks again for your help.

Kind regards
Chris Dann

Sorry for the late.
Did this still be an issue? seems rm -rf /root/.cache/gstreamer-1.0/
works after you run

Hi @Amycao,
Yep running fixes it. Thanks for your help.

Kind regards
Chris Dann

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.