Deepstream SDK 4.0 samples are working for RTSPStreaming is too slow

Hi,

I am trying to run deepstream sdk 4.0 samples - deepstream-app on Jetson TX2 (flashed with JetPack 4.2.1) using RTSP streams. I have been successful in running v4l2 camera stream with deepstream-app. However, I have been able to achieve success with RTSP streams, but run too slow.

Following are the changes made in the config file for running deepstream-app:

[source0]
enable=1
#Type - 1=CameraV4L2 2=URI 3=MultiURI 4=RTSP
type=1
camera-width=640
camera-height=480
camera-fps-n=30
camera-v4l2-dev-node=1
uri=file://../../streams/sample_1080p_h264.mp4
#uri=rtsp://admin:abc.0714@169.254.5.64:554/h264/main/ch1/main/av_stream
num-sources=12
#drop-frame-interval=2
gpu-id=0
# (0): memtype_device   - Memory type Device
# (1): memtype_pinned   - Memory type Host Pinned
# (2): memtype_unified  - Memory type Unified
cudadec-memtype=0

[sink0]
enable=1
#Type - 1=FakeSink 2=EglSink 3=File
type=2
sync=1
source-id=0
gpu-id=0
qos=0
nvbuf-memory-type=0
overlay-id=1

[sink2]
enable=1
#Type - 1=FakeSink 2=EglSink 3=File 4=RTSPStreaming
type=4
#1=h264 2=h265
codec=1
sync=0
bitrate=4000000
# set below properties in case of RTSPStreaming
rtsp-port=8554
udp-port=5400

when running this code:

deepstream-app -c /home/nvidia/xiongqf/software/deepstream_sdk_v4.0_jetson/samples/configs/deepstream-app/source12_1080p_dec_infer-resnet_tracker_tiled_display_fp16_tx2.txt

I am able to access the RTSP stream using the following gstreamer command.

gst-launch-1.0 rtspsrc latency=1 location=rtsp://127.0.0.1:8554/ds-test ! rtph264depay ! h264parse ! omxh264dec   ! nveglglessink -e

At last, we got the result as follows:

Additional debug info:
gstbasesink.c(2902): gst_base_sink_is_too_late (): /GstPipeline:pipeline0/GstEglGlesSink:eglglessink0:
There may be a timestamping problem, or this computer is too slow.

Hi,
Please set ‘sync=0’ in sink0.

Example of running rtsp source:
https://devtalk.nvidia.com/default/topic/1058086/deepstream-sdk/how-to-run-rtp-camera-in-deepstream-on-nano/post/5366807/#5366807

I just set ‘sync=0’ in sink0, but it doesn’t work, also running too slow!

Hi,
Do you also execute ‘sudo nvpmodel -m 0’ and ‘sudo jetson_clocks’?

Yes, I did, if there have any other reasons?

Hi,
Please set type=5 in sink0 to use Overlay and try sync=0

[sink0]
enable=1
#Type - 1=FakeSink 2=EglSink 3=File
<b>type=5</b>
<b>sync=0</b>
source-id=0
gpu-id=0
qos=0
nvbuf-memory-type=0
overlay-id=1

You may be misunderstanding my thought! My idea is using RTSPStreaming. then on another terminal or host get the pushing-stream. when we get stream, the stream is too slow!

Hi,
Please try ‘nvoverlaysink sync=0’

gst-launch-1.0 rtspsrc latency=1 location=rtsp://127.0.0.1:8554/ds-test ! rtph264depay ! h264parse ! omxh264dec ! nvoverlaysink sync=0 -e

hi, I also want to speed up the RTSP streaming speed. How did you solve this problem?