Deepstream stops execution but does not exit while performing FR

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) GPU
• DeepStream Version 5.1
• JetPack Version (valid for Jetson only)
• TensorRT Version 7.2.3
• NVIDIA GPU Driver Version (valid for GPU only) 460+
• Issue Type( questions, new requirements, bugs) Question
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)

The issue arisies when I run the app from deepstream-facenet for facial recognition from RTSP cameras. I have modified the code to create 4 sources for 4 RTSP streams. When the code is run, initially it runs fine and infers with no issue at all but after 700-1000 frames it stops printing output and predicting but it still shows the process as running when I run ‘nvidia-smi’

There is no clue in your description.

Hey Fiora, let me elaborate some more:

I have 4 rtsp cameras on which I would like to run a Facial Recognintion attendance system, I create 4 sources for these cameras in the deepstream pipeline which get connected to the streammux. The streammux pushes the frames to a Face detector which in turn pushes the detected faces to the face recognintion method. Both these methods are called through probes connected to the nvvideoconv part of the pipeline.

The pipeline runs with no issues and performs its required task for a few minutes but then it stops running without throwing an error and the program also fails to exit.

The code is taken from the following repository:

For rtsp sources, you can refer to deepstream-test3 sample.

And you can use “export GST_DEBUG=3” to enable gstreamer log. Basic tutorial 11: Debugging tools (gstreamer.freedesktop.org)

I have used this, nothing comes up that’s out of the ordinary. I have implimented the same using queues which I have taken from deepstream-test-3 but the FPS is still around 10 FPS whereas the camera output is 30 FPS. Is this to be expected?

The FPS is decide by the whole pipeline but not only by camera. Troubleshooting — DeepStream 5.1 Release documentation

Now I am unable to perform FR.
Let me elaborate a little on my pipeline structure:
Streammux(Sinkpad → SrcPad) → queue1 ->(Face_detector) nvinfer ->(Face_classifier) nvinfer → queue2 → nvtiler-> queue3 → nvvidconv → queue4 ->sink

2 probe functions have been added to tiler by using add_probe to tiler.get_static_pad(“sink”)

Do let me know if my pipeline looks okay and if it is wrong could you point me to an example or resource that would help?

With the above pipeline the application ran for about 15 minutes and then execution stopped with no error message. I don’t see my debug print statements printing.