Deepstream test1 python app cannot detect decoder

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) H100
• DeepStream Version 6.4
• JetPack Version (valid for Jetson only)
• TensorRT Version 8.6
• NVIDIA GPU Driver Version (valid for GPU only) 535
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Hi, currently i have tested on my local PC on the deepstream6.4 sample python app(test1) with RTX3050, and it is working fine. However, in my H100 pc prompts the below error when i run the same application:

Creating Pipeline

Creating Source

Creating H264Parser

Creating Decoder

Creating EGLSink

Playing file /home/itmax/deepstream_python_apps/apps/MiConv.com__crowd_ind.h264
Adding elements to Pipeline

Linking elements in the Pipeline

/home/itmax/deepstream_python_apps/apps/deepstream-test1/deepstream_test_1.py:220: DeprecationWarning: Gst.Element.get_request_pad is deprecated
  sinkpad = streammux.get_request_pad("sink_0")
Starting pipeline

Failed to query video capabilities: Invalid argument
libv4l2: error getting capabilities: Invalid argument
Error: gst-resource-error-quark: Error getting capabilities for device '/dev/nvidia0': It isn't a v4l2 driver. Check if it is a v4l1 driver. (13): v4l2_calls.c(99): gst_v4l2_get_capabilities (): /GstPipeline:pipeline0/nvv4l2decoder:nvv4l2decoder:
system error: Invalid argument

Command line that i used is:

python3 deepstream_test_1.py video.h264

Any advice to solve this?

This is an installation issue, try the following command, or use docker directly

sudo /opt/nvidia/deepstream/deepstream/install.sh

Thanks, it solved the issue.