Deepstream6.4 librdkafka configure

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
• DeepStream Version
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

In the process of setting up deepstream 6.4 in the gpu environment, I have a question about libdkafka. If I run the ./configure command, there are items that output failed, can I ignore all of them and move on?

checking for OS or distribution… ok (ubuntu)
checking for C compiler from CC env… failed
checking for gcc (by command)… ok
checking for C++ compiler from CXX env… failed
checking for C++ compiler (g++)… ok
checking executable ld… ok
checking executable nm… ok
checking executable objdump… ok
checking executable strip… ok
checking executable libtool… failed (disable)
checking executable ranlib… ok
checking for pkgconfig (by command)… ok
checking for install (by command)… ok
checking for GNU ar… ok
checking for PIC (by compile)… ok
checking for GNU-compatible linker options… ok
checking for GNU linker-script ld flag… ok
checking for __atomic_32 (by compile)… ok
checking for __atomic_64 (by compile)… ok
checking for socket (by compile)… ok
parsing version ‘0x020200ff’… ok (2.2.0)
checking for librt (by pkg-config)… failed
checking for librt (by compile)… ok
checking for libpthread (by pkg-config)… failed
checking for libpthread (by compile)… ok
checking for c11threads (by pkg-config)… failed
checking for c11threads (by compile)… ok
checking for libdl (by pkg-config)… failed
checking for libdl (by compile)… ok
checking for zlib (by pkg-config)… ok
checking for libcrypto (by pkg-config)… ok
checking for libssl (by pkg-config)… ok
checking for libsasl2 (by pkg-config)… failed
checking for libsasl2 (by compile)… failed (disable)
checking for libsasl (by pkg-config)… failed
checking for libsasl (by compile)… failed (disable)
checking for libzstd (by pkg-config)… failed
checking for libzstd (by compile)… failed (disable)
checking for libcurl (by pkg-config)… ok
checking for libm (by pkg-config)… failed
checking for libm (by compile)… ok
checking for liblz4 (by pkg-config)… failed
checking for liblz4 (by compile)… failed (disable)
checking for syslog (by compile)… ok
checking for rapidjson (by compile)… failed (disable)
checking for crc32chw (by compile)… ok
checking for regex (by compile)… ok
checking for rand_r (by compile)… ok
checking for strndup (by compile)… ok
checking for strlcpy (by compile)… failed (disable)
checking for strerror_r (by compile)… ok
checking for strcasestr (by compile)… ok
checking for pthread_setname_gnu (by compile)… ok
checking for nm (by env NM)… ok (cached)
checking for python3 (by command)… ok
checking for getrusage (by compile)… ok
Generated Makefile.config
Generated config.h

Yes, these are not errors, just some environment variable detection failures.

For example, if you export CC=gcc

This item will disappear and will have no impact on compilation.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.