DeepStreamSDK 6.0.0: deepstream-3d-action-recognition run failed

I make the project deepstream-3d-action-recognition, and it is ok.
But when I run :
deepstream-3d-action-recognition -c deepstream_action_recognition_config.txt
, it occurs an error: One element could not be created. Exiting.

I think the reson might be this:
but I don’t know how to solve it.
Then I try to make the project gst-nvdspreprocess, still errors :
nvidia@nano:/opt/nvidia/deepstream/deepstream-6.0/sources/gst-plugins/gst-nvdspreprocess$ sudo make

-fPIC -DHAVE_CONFIG_H -std=c++17 -Wall -Werror -DDS_VERSION=“6.0.0” -I /usr/local/cuda-10.2/include -I include -I …/…/includes -DWITH_OPENCV -pthread -I/usr/include/gstreamer-1.0 -I/usr/include/orc-0.4 -I/usr/include/gstreamer-1.0 -I/usr/include/glib-2.0 -I/usr/lib/aarch64-linux-gnu/glib-2.0/include -I/usr/include/opencv4/opencv -I/usr/include/opencv4

g++ -o gstnvdspreprocess.o gstnvdspreprocess_allocator.o nvdspreprocess_property_parser.o -shared -Wl,-no-undefined -L/usr/local/cuda-10.2/lib64/ -lcudart -ldl -L/opt/nvidia/deepstream/deepstream-6.0/lib/ -lnvdsgst_helper -lnvdsgst_meta -lnvds_meta -lnvbufsurface -lnvbufsurftransform -lcuda -Wl,-rpath,/opt/nvidia/deepstream/deepstream-6.0/lib/ -lopencv_imgproc -lopencv_core -lopencv_imgcodecs -lgstvideo-1.0 -lgstbase-1.0 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -lopencv_dnn -lopencv_gapi -lopencv_highgui -lopencv_ml -lopencv_objdetect -lopencv_photo -lopencv_stitching -lopencv_video -lopencv_calib3d -lopencv_features2d -lopencv_flann -lopencv_videoio -lopencv_imgcodecs -lopencv_imgproc -lopencv_core

gstnvdspreprocess.o: In function `batch_transformation(NvBufSurface*, NvBufSurface*, CustomTransformParams&)':

gstnvdspreprocess.cpp:(.text+0x4788): undefined reference to `NvBufSurfTransformAsync’

gstnvdspreprocess.o: In function `gst_nvdspreprocess_on_frame(_GstNvDsPreProcess*, _GstBuffer*, NvBufSurface*)':

gstnvdspreprocess.cpp:(.text+0x68b0): undefined reference to `NvBufSurfTransformSyncObjWait’

gstnvdspreprocess.cpp:(.text+0x68bc): undefined reference to `NvBufSurfTransformSyncObjDestroy’

collect2: error: ld returned 1 exit status

Makefile:81: recipe for target ‘’ failed

make: *** [] Error 1

Pls tell me how to solve this problem, thx.

Jetson nano for 4G

Jetpack 4.6

deepstream-app version 6.0.0

DeepStreamSDK 6.0.0

CUDA Driver Version: 10.2

CUDA Runtime Version: 10.2

TensorRT Version: 8.0

cuDNN Version: 8.2

From the log you attached, there maybe some problems with your JetPack system. You can check the following points:
1.Does the exist in the /opt/nvidia/deepstream/deepstream/lib/ path.
2.Check whether all the libraries it depends on is installed normally if it exists normally.

Thank you for your reply, I solved the problem by referring to this topic: Gst-plugins/gst-nvdspreprocess make error - Intelligent Video Analytics / DeepStream SDK - NVIDIA Developer Forums
update bsp package by:

$ cd /opt/nvidia/deepstream/deepstream-6.0/sources/gst-plugins/gst-nvdspreprocess
$ sudo make && sudo make install
but deepstream-3d-action-recognition runs on Jetson nano so slow, just 1 FPS when detecting 1 channel video. If switch to 2d detect model, it runs better.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.