Default ALSA asound.conf file

So, I just accidentally messed up my ALSA etc/asound.conf file.
Is it there a way to restore it? Is there a place where the default file can be found?
Thanks, sorry for the noobness


You can extract the asound.conf from the L4T Driver package. So what you can do is …

  1. Find the L4T release you are using on this page and go to the page for that release.
  2. Download the “L4T Driver Package (BSP)” for “Jetson Nano, Nano 2GB and TX1”
  3. Extract the driver package.
  4. In the driver package you will find a “nv_tegra/config.tbz2” archive and this contains the asound.conf files. Please note that there are two asound.conf files …
$ tar tf nv_tegra/config.tbz2 | grep asound.conf
  1. You should copy both of the above asound.conf.* files to the target under the /etc directory. The udev rules ‘90-alsa-asound-tegra.rules’ and ‘92-hdmi-audio-tegra.rules’ sets up a soft-link to these files depending on whether and so after copying to the target, you should just reboot and then after rebooting, /etc/asound.conf should be pointing to one of this depending if HDMI is connected or not.


Hi @jonathanh
thanks for the advice, worked perfectly!
Since i’m gonna have to change asound.conf a lot (i’m using a usb interface), i’d like to save it on a github repository, in order to have it handy, and safe.
The repository is public as well. Is it possible to upload it there or could there be a “copyright” problem?


Glad that worked. Unfortunately, I cannot personally comment on the licensing, however, I will loop in someone else to comment.


Users/developers are expected to deploy Jetson with software pre-installed and configured for use in end products, so what you describe should be fine. If you have further questions, please consult the EULA’s included in JetPack or the Tegra Software License Agreement