Delete /var/cuda-repo-l4t-11-4-local/ directory accidentally

I want to update my xavier cuda tool kit from 10.2 to 11.4.

But after I delete the older version cuda and use sdkmanager to update the tool kit, because of unenough space I delete /var/cuda-repo-l4t-11-4-local/ accidentally.

And I faild update cuda tool kit with sdkmanager. It failed with some apt access issues.

When I try to apt update it shows

$ sudo apt update
Get:1 file:/var/cuda-repo-l4t-11-4-local  InRelease
Ign:1 file:/var/cuda-repo-l4t-11-4-local  InRelease
Get:2 file:/var/cuda-repo-l4t-11-4-local  Release
Err:2 file:/var/cuda-repo-l4t-11-4-local  Release
  File not found - /var/cuda-repo-l4t-11-4-local/Release (2: No such file or directory)
Hit:3 bionic-updates InRelease
Hit:4 bionic-security InRelease
Hit:5 bionic-backports InRelease
Hit:6 bionic InRelease
Hit:7 r32.5 InRelease
Get:8 r32.5 InRelease [2,565 B]
Hit:9  InRelease
Reading package lists... Done
E: The repository 'file:/var/cuda-repo-l4t-11-4-local  Release' no longer has a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

And I tried to delete the downloaded files by sdkmanager and reinstall it, but it still failed with same apt error.

So where can I download the cuda-repo-l4t-11-14-local ?

Or something I can do to fix this problem?

Don’t know for sure, but maybe try these:

sudo apt update
sudo apt --fix-broken install
sudo apt-get --reinstall install <the CUDA package name>

I don’t know the package name, but you might check this search:
apt search cuda-repo-l4t
(only one version works with a given L4T/JetPack/SDKM release, so your release will probably work only with 11.4 and not 10.2 if you upgraded to L4T R34.x+/JetPack 5.x+)

You can’t just update the cuda version. You can only use cuda 10.2 that comes with your Jetpack 4.5.
If you want to use cuda 11.4, you need to upgrade your xavier to Jetpack 5 which comes with cuda 11.4

It shows this

$ apt search cuda-repo-l4t
Sorting... Done
Full Text Search... Done
cuda-repo-l4t-11-4-local/now 11.4.14-1 arm64 [installed,local]
  cuda repository configuration files

So I try to apt reinstall but it still failed

$ sudo apt --reinstall install cuda-repo-l4t-11-4-local
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reinstallation of cuda-repo-l4t-11-4-local is not possible, it cannot be downloaded.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

But when I try to apt update , it still failed with the same error.

Maybe you can provide me a source to download this directory?

Yeah you are right but using sdkmanager already means install jetpack automatically.

You wouldn’t normally download this. The 11.x version of CUDA is tied to the JetPack 5.x installer (as mentioned by @EzPizzy you can’t have both; but you can have one, depending on if this was a JetPack 4.x installer or 5.x installer…normally you use that to install CUDA). It is true that apt can have a repository naming the release, and in that case you can use apt to install it. I had hoped a reinstall command would fix the issue (assumes the release currently installed originally came from JetPack or apt and not a manual install). However, none of those methods simply downloads content for unpack, it is via a package mechanism, and circumventing that will probably be the road to corruption of the database.

Do you have custom content you want to save? Is that content in your home directory? Perhaps backing it up and then flashing new (along with using JetPack to install the correct release) would be the most reliable route (though slow and not as simple when backing up and restoring a piece of the system instead of just everything).

Thanks for your good suggestions, the xavier module is hidden in a box, so I can only update the cuda tool chain via Internet i think.

I guess this is some issuses with dpkg because this error disppeared after I delete some cuda related items in dpkg.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.