Depends: libnvinfer3 (>= 3.0.2) or libnvinfer3 (>= 3.0.2) but it is not going to be installed, when install TensorRT

Do you have ever met this problems when install TensorRT?

The following packages have unmet dependencies:
 tensorrt-2.1.2 : Depends: libnvinfer3 (>= 3.0.2) but it is not going to be installed
                  Depends: libnvinfer-dev (>= 3.0.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I just update cuda, it solves.

I’m having the exact same output when I try to install TensorRT-2.1.2. I have upgraded CUDA but no luck, still having the same issue. Has anyone come up with another solution, maybe the source of the problem?

I’m having that problem too when trying to install TensorRT 3.0. Anyone?

I use Ubuntu16.04 on x86, and updated CUDA to 9.1
both on CUDA 8.0 and 9.1, I cannot install tensorRT.

The following packages have unmet dependencies:
tensorrt : Depends: libnvinfer4 (>= 4.0.4) but it is not going to be installed
Depends: libnvinfer-dev (>= 4.0.4) but it is not going to be installed
Depends: libnvinfer-samples (>= 4.0.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

How can I solve this problem???

Hi futurian,

You should make sure you are download the right TensorRT version.

Ubuntu 16.04 + CUDA 9.0 download:
– TensorRT 3.0.4 for Ubuntu 1604 and CUDA 9.0 DEB local repo packages
Ubuntu 16.04 + CUDA 8.0 download:
– TensorRT 3.0.4 for Ubuntu 1604 and CUDA 8.0 DEB local repo packages

Download link: https://developer.nvidia.com/nvidia-tensorrt-download