Deploy script not working

Hello,

While running the deploy script its getting stuck in step 8 and sometimes when it self resolves step 8,it gets stuck in step 16

Details of both the errors are described below:

Error 1

Removing intermediate container f209dc28e326
—> f5656ce7d769
Step 6/17 : ENV LC_ALL=C.UTF-8
—> Running in 2a44b63bd460
Removing intermediate container 2a44b63bd460
—> 1ee8bfef541a
Step 7/17 : ENV LANG=C.UTF-8
—> Running in 689dd44b6f24
Removing intermediate container 689dd44b6f24
—> 04ce2cfb4039
Step 8/17 : RUN apt-get update && apt-get install -y --no-install-recommends python3 python3-pip curl libsm6 libxext6 libxrender-dev libglib2.0-0 && apt-get autoremove -y && rm -rf /var/lib/apt/lists/* && rm -rf /var/cache/apt/archives/partial/*
—> Running in a063ea107612
Err:1 http://security.ubuntu.com/ubuntu bionic-security InRelease
Temporary failure resolving ‘security.ubuntu.com
Err:2 http://archive.ubuntu.com/ubuntu bionic InRelease
Temporary failure resolving ‘archive.ubuntu.com
Err:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Temporary failure resolving ‘archive.ubuntu.com
Err:4 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
Temporary failure resolving ‘archive.ubuntu.com
Reading package lists…
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/bionic/InRelease Temporary failure resolving ‘archive.ubuntu.com
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/bionic-updates/InRelease Temporary failure resolving ‘archive.ubuntu.com
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/bionic-backports/InRelease Temporary failure resolving ‘archive.ubuntu.com
W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/bionic-security/InRelease Temporary failure resolving ‘security.ubuntu.com
W: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists…
Building dependency tree…
Reading state information…
E: Unable to locate package python3
E: Unable to locate package python3-pip
E: Unable to locate package curl
E: Unable to locate package libsm6
E: Unable to locate package libxext6
E: Unable to locate package libxrender-dev
E: Unable to locate package libglib2.0-0
E: Couldn’t find any package by glob ‘libglib2.0-0’
E: Couldn’t find any package by regex ‘libglib2.0-0’
The command ‘/bin/sh -c apt-get update && apt-get install -y --no-install-recommends python3 python3-pip curl libsm6 libxext6 libxrender-dev libglib2.0-0 && apt-get autoremove -y && rm -rf /var/lib/apt/lists/* && rm -rf /var/cache/apt/archives/partial/*’ returned a non-zero code: 100

Error 2

Step 16/17 : RUN pip install --no-cache-dir --upgrade setuptools && pip install --no-cache-dir /opt/nvidia/trtis-clients/python/.whl && pip install --no-cache-dir ptvsd && pip install --no-cache-dir -r ./app_malaria/requirements.txt && rm -rf /usr/local/lib/python3.6/dist-packages/future/backports/test/.pem /usr/local/lib/python3.6/dist-packages/tornado/test/test.*
—> Running in f6d63b7974e5
Collecting setuptools
Downloading https://files.pythonhosted.org/packages/a0/df/635cdb901ee4a8a42ec68e480c49f85f4c59e8816effbf57d9e6ee8b3588/setuptools-46.1.3-py3-none-any.whl (582kB)
Installing collected packages: setuptools
Successfully installed setuptools-46.1.3
Processing /opt/nvidia/trtis-clients/python/tensorrtserver-1.5.0-py2.py3-none-linux_x86_64.whl
Collecting numpy (from tensorrtserver==1.5.0)
Downloading https://files.pythonhosted.org/packages/07/08/a549ba8b061005bb629b76adc000f3caaaf881028b963c2e18f811c6edc1/numpy-1.18.2-cp36-cp36m-manylinux1_x86_64.whl (20.2MB)
Collecting protobuf>=3.5.0 (from tensorrtserver==1.5.0)
Downloading https://files.pythonhosted.org/packages/57/02/5432412c162989260fab61fa65e0a490c1872739eb91a659896e4d554b26/protobuf-3.11.3-cp36-cp36m-manylinux1_x86_64.whl (1.3MB)
Collecting future (from tensorrtserver==1.5.0)
Downloading https://files.pythonhosted.org/packages/45/0b/38b06fd9b92dc2b68d58b75f900e97884c45bedd2ff83203d933cf5851c9/future-0.18.2.tar.gz (829kB)
Collecting grpcio (from tensorrtserver==1.5.0)
Downloading https://files.pythonhosted.org/packages/cf/7a/9744998129fce7e29c5f2d8b0f545913b7383e65d8366fc0ae98d11936af/grpcio-1.28.1.tar.gz (19.5MB)
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File “”, line 1, in
File “/tmp/pip-build-ewrtoaby/grpcio/setup.py”, line 191, in
if check_linker_need_libatomic():
File “/tmp/pip-build-ewrtoaby/grpcio/setup.py”, line 152, in check_linker_need_libatomic
stderr=PIPE)
File “/usr/lib/python3.6/subprocess.py”, line 729, in init
restore_signals, start_new_session)
File “/usr/lib/python3.6/subprocess.py”, line 1364, in _execute_child
raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] No such file or directory: ‘cc’: ‘cc’

----------------------------------------

Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-build-ewrtoaby/grpcio/
The command ‘/bin/sh -c pip install --no-cache-dir --upgrade setuptools && pip install --no-cache-dir /opt/nvidia/trtis-clients/python/.whl && pip install --no-cache-dir ptvsd && pip install --no-cache-dir -r ./app_malaria/requirements.txt && rm -rf /usr/local/lib/python3.6/dist-packages/future/backports/test/.pem /usr/local/lib/python3.6/dist-packages/tornado/test/test.*’ returned a non-zero code: 1

Kindly respond

Hello,

Thank you for your interest in Clara Deploy. Can you please elaborate on exactly which deploy script you ran here? Also, a new Clara deploy SDK release is now available on NGC. Could you please try using that?